Pseudo-césure après balises inline

Alors qu'elles sont collées au mot

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous,

J'ai été confronté à un comportement surprenant aujourd'hui, et qui apparemment ne tient pas à un unique navigateur, ni à un OS (constaté sous Canary, Nightly, Internet Explorer, Safari pour iPad et pour iPhone).

Soit le code HTML suivant :

1
2
[…] NASA (<strong>N</strong>ational <strong>A</strong>eronautics and
    <strong>S</strong>pace <strong>A</strong>dministration) […]

Explication d'une abréviation sans l'habituelle balise <abbr>

Avec ce code, je me suis rendu compte que, suivant la largeur du conteneur, la "césure" se faisait non pas obligatoirement après les mots, mais après les balises <strong>, ce qui donne donc quelque chose comme

NASA (National A
eronautics and S
pace A
dministration

Exemple extrême

Je suis donc surpris dans la mesure où je pensais que même s'il y avait des balises à l'intérieur, les mots restaient considérés comme tels, donc pas de césure intempestive juste après la première lettre.

Est-ce qu'il y a un moyen autre que mettre des <span style="display: inline-block"> autour des mots pour éviter ce comportement ?

Merci d'avance

Evitez qu'on vous dise de les lire : FAQ PHP et Symfony 2Tutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0

Cette réponse a aidé l'auteur du sujet

Hmm, je suis pas convaincu par ta méthode. Un bon sélecteur CSS devrait te permettre d'isoler les premières lettres de chaque mot, ce qui te permettrait de mettre toute l'acronyme dans un truc du genre <span class="acronym">...</span>, auquel cas tu n'aurais pas ce problème de césure.

EDIT : Remarque judicieuse de mon VdD.

Édité par Richou D. Degenne

Auteur du sujet

Outre le fait que hypens: auto est une propriété considérée comme expérimentale, elle ne semble pas résoudre le problème.

Et oui, le and gêne. Mais je vais voir pour mettre des blocs autour des seuls (groupes de) mots à gérer, ça devrait le faire.

Avec vos remarques, je déduis que le comportement observé est donc normal ?

Evitez qu'on vous dise de les lire : FAQ PHP et Symfony 2Tutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte