Configuration d'un adaptateur wifi sur raspberry

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous, je me suis acheté un Raspberry pi 2 modèle B il y a quelques temps et après divers essais de manipulations sur Raspbian je me suis dit qu'il était temps d'y ajouter le wifi (je n'aurai peut-être pas dû…) enfin bref, toujours est-il que j'ai acheté une adaptateur wifi Edimax modèle EW-7811Un et j'ai attaqué la configuration… Bon avant de vous exposer mon problème il faut savoir que j'ai un niveau de collégien au niveau électronique, informatique, programmation, etc… Donc il y a une configuration détaillée à cette adresse: http://www.savagehomeautomation.com/raspi-edimax-ew-7811un j'ai suivi les instructions à la lettre mais le problème est que je n'ai pas les mêmes infos quand j'écris les commandes puis pour la suite de la config il il faut modifier un fichier nommé "interfaces" et je me rend compte que le fichier que j'ai à pas mal de différences avec celui donné sur le site j'ai malgré tout continué en tentant de m'adapter mais au final cela ne fonctionne pas. Après de nombreux essais et heures de recherches je ne trouve toujours pas. Si quelqu'un peut me venir en aide je lui ferai parvenir le contenu du/des fichiers.

Bonne journée à tous et merci d'avance.

+0 -0

Bonjour,

Que souhaites-tu faire avec le wifi ? Seulement te connecter à d'autres réseaux ? Créer le tien (faire un point d'accès) ?

Pour l'instant, on ne peut pas faire grand chose pour toi. Pourrais-tu nous donner les résultats des commandes fournies dans la partie dédiée à l'installation (lsusb, lsmod et iwconfig), une fois la carte wifi branchée à la RPi ?

+0 -0

Un premier pas intéressant pour la résolution du problème serait de poster le fichier interfaces justement, en plus de ce que Vayel demande !

Tu peux aussi utiliser d'autres outils comme wicd(-curse) si ça te convient plus, qui sont bien plus facile à utiliser sans connaissances.

+0 -0
Auteur du sujet

Merci de vous être intéressé à mon problème mais par chance un ami à qui j'avais posé la question à pu m'aider et à résolu mon problème via l'interface graphique. Malgré tout j'aimerai connaître la solution en ligne de commandes donc voici les infos

Quand je fait lsusb il voit l'adaptateur sur la dernière ligne: Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

Pour lsmod sur la ligne 8192 on a: 8192cu 528365 0

Enfin pour iwconfig le wlan0 apparait bien

Le fichier interfaces:

auto lo iface lo inet loopback

auto eth0 allow-hotplug eth0 iface eth0 inet manual

auto wlan0 allow-hotplug wlan0 iface wlan0 inet manual wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1 allow-hotplug wlan1 iface wlan1 inet manual wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

unidan pourrait tu me dire ou son disponibles ses outils car je n'en ai jamais entendu parler donc si tu pouvais prendre quelques minutes pour m'expliquer en quoi ils consistes si sa ne te dérange pas bien entendu.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte