Attack in the middle

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Salut chers (chères) zesteurs (zesteuses),

J'ai commencé une application avec Symfony2, et j'avais pas de soucis pour mettre à jour et installer mes dépendances jusqu'à il y a peu. La première fois que j'ai eu ce souci, je me suis dit que ça devrait passer en lisant le message, sauf que jusqu'à aujourd'hui ce n'est pas le cas. En attendant je copiais des packages d'autres projets et les installais à la main(sachant que c'est pas une solution) et là j'ai encore besoin d'un package que j'ai pas sous la main.

Bon trêve de bavardages et place aux retours de composer

1
2
3
4
[Composer\Repository\RepositorySecurityException]
  The contents of http://packagist.org/p/provider-2014%2417dbda5d22d7691fe8448cb4b3a0b8307a66f8295ac583bdb72143464b7c
  1ac3.json do not match its signature. This should indicate a man-in-the-middle attack. Try running composer again a
  nd report this if you think it is a mistake.

Donc j'aimerais bien qu'une âme bien aiguisée me montre la voie. Merci à vous de votre précieuse aide.

You got it.

+0 -0

Salut !

Est-ce que cette erreur est systématique ? As-tu une version à jour de Composer ? Est-ce que les informations de débogage de Composer (ajouter -v) te permet de mieux comprendre le souci ?

J'ai tenté de me rendre à l'adresse mentionnée dans ton message d'erreur, je reçois une 404. Ça sent l'URL invalide, que ce soit dans le cache de Composer ou les informations récupérées pour le construire.

Evitez qu'on vous dise de les lire : FAQ PHP et Symfony 2Tutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0
Auteur du sujet

Salut Ymox!

Tout d'abord merci de ton intervention. Je viens d'essayer avec l'option -v comme tu me l'a proposé et là miracle tout se passe à merveille. Que s'est il passé? Je ne saurais te dire, mais depuis hier, il y avait une idée qui me trottait dans la tête et ce test de tout à l'heure regroupe aussi cela..

En fait, le test que je viens d'essayer, c'est avec un autre FAI, c'est pas le première fois que je me retrouve avec un problème similaire et je pense que c'est là le problème.

Une fois, j'ai voulu installer cordova ( avec npm) mais je n'arrivais toujours pas, en changeant de FAI, ça résolu le problème et là on dirait que c'est pareil ( je vais refaire le test avec mon FAI lundi pour m'en assurer).

Merci et je tiendrais informé si l'erreur resurgi avec mon FAI habituel..

Bonne journée et bon weekend.

You got it.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte