Ethernet Arch

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour

Comme KDE (plasma) ne me convenait pas j'ai décider de la remplacer par Xfce, la suppression de KDE et plasma a bien fonctionner mais quand j'ai voulu installer Xfce je me suis rendue conte qu'il n'y avais pas de connexion Internet alors que j’étais branché en filaire. pour info j'ai NetworkManage et pour des info sur le système (un petit uname -a) Linux jamie 4.4.5-ARCH et x86_64 .

merci d'avance.

Édité par ilistro

+0 -0

Clic droit sur l'icône de Network Manager dans la zone de notifications > Modifications des connexions > Ajouter une connexion > Type : Ethernet

Et normalement, ça marche.

La vie, c'est comme les mirabelles

+0 -0
Auteur du sujet

pas con mais si sa ne marche pas je suis un peux embêté! afin je pourrais toujours récup les fichiers a partir d'un autre ordi (j'aime bien quand je répond a moi même).

Édité par ilistro

+0 -0

Non, tu pourras toujours réinstaller NetworkManager, le paquet est gardé en cache. Faut juste pas vider le cache (Éviter la commande pacman -Sc)

La vie, c'est comme les mirabelles

+0 -0

Tout d'abord sachez que je n'ai pas d'Arch sous la main. Mon aide sera donc limitée.

Le fichier /etc/network/interfaces est utilisé par Debian, mais ne semble par être utilisé par Arch. Il y a d'autres fichiers en fonction de ta configuration. La documentation se trouve ici.

Pour le dossier netctl, je suppose qu'il faut avoir netctl d'installé et que ce n'est pas ton cas.

Quelques questions pour mieux situer :
- Tu cherches à te connecter en DHCP ou en IP statique ?
- De quels utilitaires réseau disposes-tu ? Je ne vois pas network-manager dans la doc, mais il y a d'autres services et utilitaires qui devraient permettre la configuration.

+0 -0
Auteur du sujet

J'ai réussi à installer Xfce en utilisant le wifi, donc plus facile pour ethernet. Mais j'ai un problème avec Leightdm,je ne peus pas en dire plus car je n'ai pas le pc sous la main mais j'en dirais plus demain.

+0 -0
Auteur du sujet

Voici l'erreur dont j'avais parlé:

1
2
3
# abel at jamie in ~ [12:51:45]
$ sudo systemctl enable lightdm
Failed to execute operation: File exists

Édité par ilistro

+0 -0

Cette page donne la solution.

Il faut d’abord désactiver l'ancien display manager (dm) avant d'activer le nouveau (pacman ne le fait pas). Comme tu a désinstallé kde l'ancien dm est donc kdm, (il ne se foule pas pour les prenoms chez kde mais ça a le mérite d'être clair).

les lignes à taper sont donc :

1
2
$ sudo systemctl disable kdm
$ sudo systemctl enable lightdm

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0
Auteur du sujet

Je suis un barbare, moi j'utilise FORCE (-f), HARRRRRRRRRRRRRRRRRRRRRRRRRR. Mais si je l'avais su plutôt j'aurais bien évidemment (moi qui croyais que sa s'écrivait évidament) utilisé ta technique ;)

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte