Visibilité de mon serveur

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour ! J'ai un petit soucie avec mon wampserver, j'aimerai utilisé la fonction "Passer en ligne" mais je ne sait pas top comment m'y prendre. J'ai procédé aux étapes suivantes: - Transféré le port 80 de ma box (numericable) vers l'adresse ip de mon ordinateur suivant le protocole TCP - Autorisé Apache dans mon pare-feu windows (j'ai cocher public et priver) - J'ai lancer les services wamp

Le problème est que personne ne peut avoir accès à mon site en développement ni depuis l’extérieur, ni depuis l’intérieur de mon réseaux domestique.

Je cherche quelqu'un qui saurai me dépanné.

/!\ Je souhaite utilisé cette méthode car je ne souhaite pas loué un espace FTP pour effectué 3 tests, se serai stupide.

+0 -0
Staff

Je ne connais pas WAMP mais souvent il y a une option pour ouvrir le serveur vers le reste du monde (ce qui n'est pas le cas par defaut). De plus les serveurs de tests sont rarement sur le port 80 et je te le déconseille. Utilise plutôt un port comme le 8080 ou 8000.

+0 -0

Salut !

Est-ce que tu as suivi la partie du tutoriel qui en parle, par hasard ?

Est-ce que tu as créé un hôte virtuel sur ta machine ?
L'as-tu renseigné sur les autres ordinateurs ?
Tu ne précises pas, mais est-ce que tu as bien "coché" « Passer en ligne » pour WAMP ?
Et pour pallier toute éventualité, quelle version de WAMP utilises-tu ?

Édité par Ymox

Evitez qu'on vous dise de les lire : FAQ PHP et Symfony 2Tutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0
Auteur du sujet

@Ymox : Non je n'ai pas vu le tuto, mais merci de m'avoir passé le lien. J'ai effectivement activé "Passer en ligne" sur wamp après mes manip' Je possède WampServer 2.5

@Phigger : Je souhaite plutôt utiliser l'adresse ip, je pense qu'il y aura moins de manip' à effectuer

EDIT: Je vient de passé à WampServer 3, habituellement je préfère être à jour

Édité par Aire Ayquaza

+0 -0

Est-ce que tu peux nous expliquer et montrer ce que tu as fait et mis dans les différents fichiers sur les différents ordinateurs ?

Édité par Ymox

Evitez qu'on vous dise de les lire : FAQ PHP et Symfony 2Tutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0
Auteur du sujet

J'ai créé avec wamp le virtual host suivant : forumv4.local que j'ai linker au dossier C:\wamp\www\forumv4 Ensuite j'ai suivit ton tuto et effectuer les manip' suivantes:

  • J'ai décommenté la ligne 'Include conf/extra/httpd-vhosts.conf' dans le fichier de config d'apache. Dans le fichier httpd-vhosts.conf il y a donc (Généré par wamp):
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
<VirtualHost *:80>
    ServerName localhost
    DocumentRoot C:/wamp/www
    <Directory  "C:/wamp/www/">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require local
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName forumv4.local
    DocumentRoot c:/wamp/www/forumv4
    <Directory  "c:/wamp/www/forumv4/">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require local
    </Directory>
</VirtualHost>
  • Puis sur mon ordinateur les lignes suivante ont été ajoutées à mon fichier hosts:
1
2
127.0.0.1   forumv4.local
::1         forumv4.local
  • Sur l'ordinateur de mon frère (LAN) le fichier hosts contient
1
2
192.168.0.11 forumv4.local
%MON_ADRESSE_MAC% forumv4.local
  • Sur celui de mon cousin (WAN) :
1
2
%MON_IP_PUBLIQUE% forumv4.local
%MON_ADRESSE_MAC% forumv4.local
  • Sur mon routeur j'ai configuré un transfère de port pour que les requêtes sur le port 80 soient redirigée vers l'ip 192.168.0.11

  • Pour finir j'ai autorisé Apache pour les domaines publics et privés dans mon pare-feu windows

  • Enfin sur "Passer en ligne" sur wamp

EDIT: Wamp n'est installé que sur l'ordinateur d'ip 192.168.0.11 sur mon réseaux local et n'est pas installé chez mon cousin (pas besoin)

Édité par Aire Ayquaza

+0 -0

Il n'est jamais mention de l'adresse MAC dans le tutoriel, et l'adresse IPv6 n'a pas de lien aussi direct que ça avec l'adresse MAC (d'ailleurs, le terme d'adresse est un peu déroutant dans ce cas).

Dans les deux hôtes virtuels que tu as mis, il y a Require local, dont il n'est pas non-plus question dans le tutoriel (car il y a aussi une partie sur les hôtes virtuels). Cette directive va faire que WAMP retourne un statut 403 pour tous les ordinateurs qui tenteraient de se connecter au tien, parce que cela limite l'accès en local (et surtout depuis la même machine) uniquement. Si pour localhost ce n'est pas un problème, pour l'autre, ça ne va pas fonctionner.

Maintenant, quand tu dis que "ça ne fonctionne pas", est-ce que tu as un message d'erreur qui s'affiche et dont tu pourrais nous faire part ?

Édité par Ymox

Evitez qu'on vous dise de les lire : FAQ PHP et Symfony 2Tutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0
Auteur du sujet

Le message que les autres ordinateurs reçoivent est le suivant : Ce site est inaccessible.

Effectivement, j'ai voulu aller trop vite, et c'est bien l'adresse IPv6 qui est dans les fichiers hosts et non pas l'adresse MAC.

Concernant le Require local, c'est wamp qui à généré cela, y à t'il d'autres valeurs à part local ? ou doit-je supprimer cette ligne pour chaque virtual host ?

+0 -0

Si cela ne laisse que la machine accéder à elle-même pour ces hôtes virtuels, je pense bien qu'il faut les enlever… Mais comme dit avant, pas besoin de le faire pour l'hôte virtuel avec ServerName localhost.

C'est marrant, la dernière fois que j'avais généré un hôte vituel avec ce que WAMP propose, je n'avais pas le même résultat.

Evitez qu'on vous dise de les lire : FAQ PHP et Symfony 2Tutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0
Auteur du sujet

Le navigateur c'est chrome et le message est le suivant:

1
2
3
4
Ce site est inaccessible

forumv4.local a mis trop de temps à répondre.
ERR_CONNECTION_TIMED_OUT

EDIT: ça y est ça fonctionne pour le LAN, j'avais juste oublier d'autorisé le port 80 dans mon pare-feu :facepalm: j'editerai quand je serai sûr pour le WAN

EDIT2: Le WAN fonctionne aussi

Édité par Aire Ayquaza

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte