Quand un article et un tuto ont le même nom, la suppression cause des 404

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous.

Quand un article et un tutoriel ont le même nom, supprimer l'un semble aussi supprimer aussi l'autre, ou tout du moins le rend inaccessible avec une belle erreur 404. Cela vient de m'arriver avec un de mes tutoriel, quand j'ai décidé de migrer un article pas encore paru en tutoriel à grand coup de copier-coller. En supprimant l'article, le tutoriel est devenu inaccessible : il est toujours présent dans la liste des tutoriels, mais j'obtiens une 404 quand j'essaie d'y accéder. A noter que la galerie n'a pas disparue et est toujours liée au tutoriel, pas à l'article (qui a bien été supprimé sans problème).

C'est le genre de bug qui fait dire "Aie".

Édité par anonyme

+0 -0
Staff

Merci Mewtow, on va corriger ça très rapidement.

EDIT : Je n'arrive pas à reproduire en local ni sur la version de production. Est-ce que tu peux me dire quand les contenus ont été créés et le titre idéalement ? Je pense que tu as trouvé un bug mystère :) Pour moi c'est lié à du vieux contenu et ce n'est plus d'actualité mais c'est à confirmer.

Édité par gustavi

"I think that it’s extraordinarily important that we in computer science keep fun in computing." – Alan J. Perlis

+0 -0
Staff

Encore les slugs peuvent être identiques mais on identifie les contenus avec pk et non slug.

"I think that it’s extraordinarily important that we in computer science keep fun in computing." – Alan J. Perlis

+0 -0
Auteur du sujet

Est-ce que tu peux me dire quand les contenus ont été créés et le titre idéalement ? Je pense que tu as trouvé un bug mystère :) Pour moi c'est lié à du vieux contenu et ce n'est plus d'actualité mais c'est à confirmer.

gustavi

L'article et le tutoriel ont été créés hier soir, leur titre était "Comment fonctionne un logiciel de virtualisation ?" lorsque le bug est apparu. Donc non, ce n'est pas un problème lié à du vieux contenu.

Édité par anonyme

+0 -0
Staff

Alors là on a LE bug mystère puisqu'il m'est impossible de le reproduire. Je vais investiguer un peu plus en détails, merci du retour.

"I think that it’s extraordinarily important that we in computer science keep fun in computing." – Alan J. Perlis

+0 -0

Hééé, Mewtow, t'es pas le seul :D j'ai le même bug mystère ^^
Pour détail mon tuto c'est : Développez votre site avec FuelPHP (encore en brouillon). Si ça peut aider j'ai synchronisé avec Zest writer et celui si au lieu de synchroniser, créer un nouveau tuto (le bug est remonté), du coup j'ai eu deux tuto avec le même nom, j'en ai supprimé un (le vide) et il est resté mais en 404. L'autre possède une URL presque identique (/developpez-votre-site-avec-fuelphp-1/)

Voili voilou :)

Un projet de gestion de container sur Zds | dryWamp une page d'accueil pour Wamp

+0 -0
Staff

Alors j'ai une bonne nouvelle : on a des logs sur l'erreur de Dryusdan ! Plus d'informations quand je sais ce que c'est, je continue d'investiguer ;)

"I think that it’s extraordinarily important that we in computer science keep fun in computing." – Alan J. Perlis

+1 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte