Problème avec l'option [L]

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour ! :)


Edit 3 : Ouf ! Je viens de trouver ! En fait, c'est le navigateur qui met en cache la nouvelle redirection. J'ai résolu mon problème grâce à cette discussion : http://stackoverflow.com/questions/9431164/cannot-remove-301-redirect


J'ai créé un dossier pour mon site dans le dossier www/my-site/ de wamp. Dedans, j'y ai mit le Framework FuelPHP.

Dans le tuto de ce Framework, il y avais ceci (à mettre dans un .htaccess) :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
<IfModule mod_rewrite.c>
    RewriteEngine on

    # Send request to the subfolder, if it's not a real file, folder or it's a root request
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d [OR]
    RewriteCond $1 ^$

    RewriteRule ^(.*)$ /deep/sub/folder [R=301,L]
</IfModule>

J'ai bien sûr remplacé le /deep/sub/folder par mon URL, mais j'ai du mettre un / de trop (ou l'inverse :p ) et quand je vais dans mon dossier ça redirige vers http://localhost/C:/wamp64/www/my-site/fuelphp/public/.

Il y à donc le C:/wamp64/www/ en trop.

Le problème, c'est que j'ai beau modifier le .htaccess, rien à faire, puisque il y à le "drapeau" [L].
Je pense donc que ça à du enregistré cette redirection quelque part dans Wamp, mais je ne sais pas où.

Du coup, je peux plus modifier l'URL Rewriting…

Quelqu'un sais où est enregistré le contenu du .htaccess quand il y à le "drapeau" [L] ?

Merci ! :)

Edit : Par contre je sais pas vraiment si le problème viens du drapeau [L]…

Edit 2 : Apparement, ça viendrais de l'option 301 qui serais une redirection permanente !

Édité par FougereBle

Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte