une erreur dans mon EfiBoot Stub

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Salut,

Hier soir, après avoir hésité longuement entre ArchLinux et Debian, j'ai choisi d'installer ArchLinux en dual-boot au côtés de Windows 10 sur mon Acer. Après avoir passé du temps à configurer mon système grâce à ce guide, je passe à l'étape du bootloader. La méthode qui m'a paru la plus intéressante était l'EfiBoot Stub, j'ai donc suivi ceci puis cela.

Ma commande efibootmgr me montre bien l'amorçage que je viens de créer, dans l'ordre : USB, Arch, WindowsBootloader, CD, network.
Or lorsque je démarre mon ordinateur (en ayant retiré la clé d'installation), il boot sur windows 10, et lorsque je vais voir l'ordre des boot dans l'UEFI, il n'y a pas de nouveau boot par rapport à avant l'installation d'archlinux. Alors je retourne sur l'installeur et exécute la commande efibootmgr et l'entrée Archlinux est bien là.

Une idée de ce qu'il peut se passer ?

mes partitions sont :

  • sda1: Efi (100 Mo)
  • sda2: WindowsBootLoader (chéplumépatouché Go)
  • sda3: Windows (~480 Go)
  • sda4: Linux swap (8 Go)
  • sda5: Linux FileSystem (~450 Go)
  • sda7: Partition de récupération sortie d'usine Windows (chéplumépatouché Go)

Édité par leroivi

Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison - Coluche

+0 -0
Auteur du sujet

J'ai laissé tombé la commande efibootmgr et ai essayé de configurer par un uefi shell avec la commande bcfg.
Le problème n'est plus le même :

  • j'ai ajouté mon entrée avec bcfg boot add 0 fs1:\EFI\arch\vmlinuz-linux.efi "ArchLinux"
  • j'ai ajouté les options avec bcfg boot -opt 0 fs1:\EFI\arch\bootoptions en ayant ecrit mes options de boot dans bootoptions avec la commande edit. J'ai fait cela car lorsque j'entrais mes options entre guillemets, la commande me retournais "invalid arguments"
    J'ai essayé plusieurs contenu de bootoptions, j'aimerais à terme y indiqué l'UUID du disque, sinon le contenu le plus simple que j'ai utilisé est root=/dev/sda5 initrd=\EFI\arch\initramfs.img"
  • je redémarre et vais dans mon menu de boot, ArchLinux est présent mais pas dans la bonne priorité
  • je retourne dans le uefi shell et la commande bcfg boot dump me montre que ArchLinux a effectivement changé de priorité tout seul !
  • je me dis que c'est pas très grave que ce ne soit pas le système prioritaire et redémarre l'ordi pour booter sur ArchLinux, et je me retrouve dans un emergency shell car le kernel n'a pas reussi à trouver root (qu'il considère comme vide)

Un des truc que je suspecte : Lorsque je regarde les options avec bcfg boot dump -v -b, avant les options root=[..] se trouvent 2 caractères 0xFF et 0xFE.

Toujours preneur pour d'éventuelles pistes pour terminer mon installation.

Ce n'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison - Coluche

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte