Kernel panic aléatoire

a marqué ce sujet comme résolu.
Auteur du sujet

Bonsoir !

Cela fait un moment que j’ai des kernel panic à des moments assez aléatoires, je n’ai toujours pas réussi à savoir précisément d’où vient la cause et je ne trouve rien dans les logs (ce qui est étrange). Lorsque le problème arrive, tout le pc freeze totalement d’un coup, plus rien ne répond et je suis contraint de rester appuyé sur le bouton power pour redémarrer. Je n’ai jamais rien perdu en termes de fichiers ou eu de problème de corruption au démarrage (en tout cas je n’ai rien observé de la sorte pour le moment). Ces kernel panic peuvent arriver deux fois à 10min d’écart, comme une fois toutes les semaines.

Ce caractère aléatoire rend difficile l’étude du problème, d’où ce post. Pendant longtemps j’ai suspecté vim d’être la cause du problème simplement car les freeze arrivaient très souvent pendant que je codais, j’ai donc désactivé tous les plugins, mais ça n’a rien changé et puis plus tard j’ai eu ces kernel panic sans utiliser vim. J’ai aussi suspecté mon adaptateur ethernet de causer le problème, mais encore une fois j’ai eu un contre-exemple en wifi. Bref ça devient compliqué de savoir d’où vient le problème.

Système :

Matériel:

  • Macbook Pro 2015

Pour ce qui est des logs j’ai consulté /var/log/kernel.log et /var/log/syslog sans grand succès. Un exemple de kernel.log (le freeze a eu lieu entre 20:25:50 et 20:28:29, à noter que les elf segfault avant le crash viennent de moi qui codait quelque chose, des crash ont déjà eu lieu quand je ne codais pas). Après redémarrage voici la sortie de dmesg.

Du coup si vous avez des pistes ou des idées d’où peut bien provenir ce problème ça serait avec grand plaisir ! :) Merci d’avance de votre aide.

Édité par haltode

+0 -0
Auteur du sujet

Effectivement c’est une bonne idée ! Mais je ne pense vraiment pas que ça vienne du matériel, car j’ai oublié de le préciser mais j’étais sous Arch avant et je n’avais absolument pas ces problèmes (et puis mon ordi est assez récent).

Je vais quand même vérifier ça mais pour l’instant je rencontre pas mal de problèmes avec memtest (ça par exemple), ou alors mes clés usb ne sont pas reconnus par mon ordi. Bref, je te tiens au courant de tout ça ;)

EDIT: Bon mon problème avec memtest semble venir de BIOS vs. UEFI, du coup j’ai un peu abandonné de ce côté, par contre j’ai fait des tests avec memtester qui ne teste pas TOUTE la mémoire mais qui a l’avantage de pouvoir être exécuté en userspace. Après plusieurs passes, tout est normal de ce côté là.

Édité par haltode

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte