Machine virtuelle et accès réseau

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous.

Mon laptop tourne sous Fedora 27 et je cherche à faire tourner via KVM une marchine virtuelle avec un Ubuntu 16.04 dessus. Je n’ai aucun soucis pour installer la machine virtuelle mais je n’arrive pas à avoir du réseau avec (apt ne marche, pas de ping, bref rien).

Lors de l’installation de la VM, virt-manager m’affiche dans la plupart des cas macvtap ne fonctionne pas pour les communications réseaux entre hote et invité.

En farfouillant un peu le net, j’ai exécuté les commandes suivantes sur mon système host:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
[root@linux ~]# cat network-kvm.xml 
<network>
  <name>macvtap-net</name>
  <forward mode="bridge">
    <interface dev="wls1"/>
  </forward>
</network>
[root@linux ~]# virsh net-define network-kvm.xml
[root@linux ~]# virsh net-autostart macvtap-net
[root@linux ~]# virsh net-start macvtap-net

J’ai redémaré pour être sûr et j’ai changé la conf réseau de la machine virtuelle pour qu’elle soit sur le réseau virtuel macvtap-net (ce qui a retiré le warning) et j’ai booté la VM.

La config réseau dans la VM ressemble à ca scren

Ma config réseau host ressemble à ca

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
enp60s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 9c:5c:8e:41:b0:78  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 4  bytes 340 (340.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 340 (340.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

macvtap0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::5054:ff:fe83:acb7  prefixlen 64  scopeid 0x20<link>
        ether 52:54:00:83:ac:b7  txqueuelen 500  (Ethernet)
        RX packets 1072  bytes 96682 (94.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 624  bytes 60968 (59.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wls1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.23  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::a764:191:11dc:a8af  prefixlen 64  scopeid 0x20<link>
        inet6 2a01:cb19:85f3:f300:ae7:ae53:a7cb:813a  prefixlen 64  scopeid 0x0<global>
        ether 4c:eb:42:ca:49:af  txqueuelen 1000  (Ethernet)
        RX packets 35131  bytes 24240287 (23.1 MiB)
        RX errors 0  dropped 106  overruns 0  frame 0
        TX packets 24658  bytes 5009080 (4.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Je n’ai aucune idée de qui ne pas, surtout qu’auparavant, ca marchait sans encombre avec une option NAT (de mémoire).

Je serai vraiment reconnaissant de toute aide.

Merci, David

Édité par Davidbrcz

+0 -0

Hello,

Je ne connais mac macvtap du tout, est-ce que ça a un intérêt plutot que créer ton bridge toi-même ?

Je suis tombé sur ça https://virt.kernelnewbies.org/MacVTap, à la fin il précise que qemu ne supporte pas macvtap directement. Je ne sais pas à quel point c’est vrai mais peut être que passer en vrai configuration de bridge permettra de résoudre ton problème initial.

+0 -0
Auteur du sujet

Bon, en farfouillant sur le net, je suis tombé sur cette page qui m’a permis de rajouter un bridge, ce qui fait ca marche \o/

En résumé, ls mêmes commandes que dans le premier message mais avec le fichier suivant

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
[root@linux-2 david]# cat br.xml
<network>
  <name>br1</name>
  <forward mode='nat'>
    <nat>
      <port start='1024' end='65535'/>
    </nat>
  </forward>
  <bridge name='br1' stp='on' delay='0'/>
  <ip address='192.168.10.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.10.10' end='192.168.10.100'/>
    </dhcp>
  </ip>
</network>
[root@linux ~]# virsh net-define br.xml
[root@linux ~]# virsh net-autostart br1
[root@linux ~]# virsh net-start br1
+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte