Image, alt et legendes. La bonne facon ?

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

Depuis la v27, les images ne fonctionnent plus. Avant, un code comme celui-là:

![alt](url)

Affichait l’image au centre mettait un alt ET une légende. Ducoup, quand je ne voulais pas de légende, je faisais :

![](url)

Ce qui ne mettait ni alt ni légende.

Je m’attends à ce que v27 ne casse pas la compatibilité avec les anciens tuto.

Ducoup je me demande :

Dois-je retaper toutes les intégrations des images de mes tutoriels pour qu’elles marchent sous la forme :

![alt](url)
Figure : legende

Ou est-ce qu’un correctif futur va venir régler ce souci et réassurer la compatibilité précédente ?

Un gros merci d’avance pour vos réponses ! :)

+0 -0

Attention que c’est Figure:.

Dois-je retaper toutes les intégrations des images de mes tutoriels pour qu’elles marchent sous la forme :

C’est ce que j’ai fait pour mes contenus (ce fut assez rapide). Maintenant, un correctif ne serait pas mal vu la masse de contenus publiés avant la v27.

Édité par Arius

Auteur du sujet

Je rebondis pour vous remonter deux bug.

Le bug principal semble avoir été corrigé :

![toto](tutu.jpg)

Devient :

<figure>
<img src="tutu.jpg" alt="toto">
<figcaption>toto</figcaption>
</figure>

L’image est centrée, et ça c’est bien. Un gros merci ! :)

Image seule non centrée

Mais dans ce cas ci (pas de texte) :

![](tutu.jpg)

On obtient :

<p><img src="tutu.jpg"></p>

Et l’image n’est pas centrée. La balise CSS display: block semble s’appliquer a .main .content-container .article-content figure > img

Si je remplace la balise p :

<p><img src="tutu.jpg"></p>

Par figure :

<figure><img src="tutu.jpg"></figure>

Le CSS s’applique correctement et l’image est centrée. Donc il semble qu’il y ai encore un bug pour les images sans texte.

Formatage markdown non appliqué dans <figurecaption>

Avant, ceci :

![toto *est* sympa](tutu.jpg)

Donnait ceci :

<figure>
<img src="tutu.jpg" alt="toto est sympa">
<figcaption>toto <i>est</i> sympa</figcaption>
</figure>

Le formatage markdown etait applique dans <figurecaption>.

En ce moment, il donne ceci:

<figure>
<img src="tutu.jpg" alt="toto est sympa">
<figcaption>toto *est* sympa</figcaption>
</figure>

Le formatage n’est pas applique.

Deux bug que je remonte donc. :)

Passez une bonne journée ! :D

+0 -0

en vérité ![toto *est* sympa](tutu.jpg) n’aurait jamais dû donner un texte formatté en légende. C’est d’ailleurs pour donner le formattage qu’on a créé l’extension qui consiste à mettre Figure:

Pour le premier, c’est un choix qu’on a fait : une image sans texte alternatif ne deviendra pas une figure car ça n’aurait aucun sens : une figure sans légende n’a aucun sens.

+2 -0
Auteur du sujet

Merci pour les réponses !

en vérité ![toto *est* sympa](tutu.jpg) n’aurait jamais dû donner un texte formatté en légende. C’est d’ailleurs pour donner le formattage qu’on a créé l’extension qui consiste à mettre Figure:

Très bien ! C’est très clair ! :)

Bon, il va falloir que je repasse sur mes images moi. :D

Pour le premier, c’est un choix qu’on a fait : une image sans texte alternatif ne deviendra pas une figure car ça n’aurait aucun sens : une figure sans légende n’a aucun sens.

OK, mais comment je fais pour avoir une image centrée ? En l’état, c’est bizarre.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte