Directive apache2 "<Directory ...>" inactive

La directive "<Directory ...>" ne réagit pas

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

J’ai voulu activer les .htaccess dans mon virtualhost mais rien n’y fait… J’ai réussi à remonter à la source du problème. <Directory "/home/user/my/full/path"> ne fait rien, le contenu n’est pas pris en compte. Avez-vous une idée ?

<VirtualHost monsite.fr:80>
    ServerName monsite.fr
    DocumentRoot "/home/airplaine/apache2/monsite/www/"

    <Location "/">
        Order allow,deny
        Allow from all
        Require all granted
    </Location>

    <Directory "/home/airplaine/apache2/monsite/www/">
        Deny from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/monsite_error.log
    CustomLog ${APACHE_LOG_DIR}/monsite_access.log combined
</VirtualHost>

Bon vol,

A.

Ma config :

 apachectl -V
Server version: Apache/2.4.10 (Debian)
Server built:   Mar 31 2018 09:39:03
Server's Module Magic Number: 20120211:37
Server loaded:  APR 1.5.1, APR-UTIL 1.5.4
Compiled using: APR 1.5.1, APR-UTIL 1.5.4
Architecture:   64-bit

NB2 : J’ai accès à : http://monsite.fr/.htaccess

NB3 : Pour le .htacces j’avais essayé :

    <Directory "/home/airplaine/apache2/monsite/www/">
        AllowOverride All
    </Directory>

Édité par A-312

+0 -0
Auteur du sujet

Cette réponse a aidé l’auteur du sujet

J’ai modifié apache.conf :

En dessous de :

<Directory /var/www/>...</Directory>

J’ai mis :

<Directory /home/airplaine/apache2/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

J’ai aussi modifié mon virtualhost :

<VirtualHost monsite.fr:80>
    ServerName monsite.fr
    DocumentRoot /home/airplane/apache2/monsite/www


    <Directory /home/airplane/apache2/monsite/www>
        AllowOverride All
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/monsite_error.log
    CustomLog ${APACHE_LOG_DIR}/monsite_access.log combined
</VirtualHost>

Ca semble mieux fonctionner ! :D

J’ai aussi fait :

# chown www-data /home/airplane/apache2 -Rf
# chmod 775 -R /home/airplane/apache2 -Rf
+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte