Arduino/Android - Modules Bluetooth HC05 ne marchent pas

Led du module ne s'allume pas / Non reconnaissance du module par le bluetooth de mon téléphone

a marqué ce sujet comme résolu.
Auteur du sujet

Bonjour à tous,

Je viens de recevoir 2 modules bluetooth HC05 (commandés sur ebay) dans l’objectif de les utiliser avec arduino et de piloter différentes choses via mon téléphone Android. Je n’ai réussi à en faire fonctionner aucun des 2. Avant de penser à un défaut de fabrication, je souhaiterais recueillir l’avis d’utilisateurs qui pourraient m’éclairer. Je n’écarte pas d’avoir oublié de faire quelque chose.

Mon Android est à la version 4.3

Ma carte arduino fonctionne très bien depuis 3 ans (ATMega 328).

Pour résumer, j’ai 2 problèmes en essayant de faire un test après avoir téléchargé un sketch dans l’arduino pour commander une led sur la broche 13 via la voie série ("a" pour allumer, "b" pour éteindre) et développer une application avec app inventor 2.

1-Lorsque je connecte mon module à ma carte arduino, à aucun moment la led du module bluetooth ne s’allume ou ne clignote, ce qui indiquerait au moins que le module bluetooth est fonctionnel. Mon branchement est le suivant : Tx module à Rx Arduino, Rx module à Tx arduino, GND module à GND arduino et VCC module au +5V de l’arduino (j’ai également testé avec le +3.3V).

2- Lorsque j’active le bluetooth sur mon téléphone Android, il ne détecte pas le module bluetooth. Mon téléphone détecte différents appareils aux alentours mais aucun qui commencerait par HC05-…….

Si quelqu’un pouvait m’orienter vers une piste pour résoudre ces problèmes.

Merci d’avance

Édité par gringo75

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte