Perte de la légende en cas d'espaces

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Dans le cas ou l'on veut centrer une image, si jamais on met des espaces apres la balise ouvrante de centrage alors on perd l'info de legende. Comme une image vaut mieux qu'un long discours…

Sans espace :

->![Indication du sens du courant](/media/galleries/954/08921932-5ed1-4bf3-9934-ceb91c560cb3.png.960x960_q85.jpg)<-

Indication du sens du courant

Avec espace :

-> ![Indication du sens du courant](/media/galleries/954/08921932-5ed1-4bf3-9934-ceb91c560cb3.png.960x960_q85.jpg) <-

Indication du sens du courant

On voit bien que dans le deuxième cas la légende est perdu :( . Est-ce bien normal ou un bug du MD ?

ZdS, le best du Zeste ! Tuto Arduino, blog, etc

+0 -0
Staff

Si tu mets des espaces, l'image n'est plus seul dans son paragraphe. Du coup le module qui test pour savoir si l'image est éligible a un passage de Image Inline à Figure avec legende considère que ce n'est pas une image isolé.

On pourrait éventuellement alléger ça en virant les espaces avant test MAIS ce point permet aussi d'insérer une image sans Figure et sans texte qui deviendrait impossible sinon.

Donc pour moi c'est pas un bug, c'est une feature.

NB: Pas besoin de demander le centrage des Figures, elles le sont déjà :

1
![Indication du sens du courant](/media/galleries/954/08921932-5ed1-4bf3-9934-ceb91c560cb3.png.960x960_q85.jpg)

Indication du sens du courant

+0 -0
Staff

Si tu as deux images côte a côte, tu ne peux pas specifier de légende non ?

Actuellement je ne crois pas qu'il y a de moyens de coller deux images dans un même élément Figure.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte