"Suivre ce forum" ne fonctionne pas tout le temps

a marqué ce sujet comme résolu.
Auteur du sujet

Bonjour,

Comme-dit dans le titre, la fonctionnalité de suivi de forum ne fonctionne pas toujours. Je n’ai pas réussi à isoler de facteur. Je l’avais déjà remarqué il y a quelques temps. Ça s’est à nouveau produit avec ce sujet qui date d’hier pourtant j’ai reçu une notification pour celui-là qui a été posté hier aussi. Les deux appartiennent au même forum.

Ça semble m’arriver assez fréquemment mais je ne parcours pas assez souvent le site pour m’en rendre compte et pouvoir être sûr de moi.

Ça n’arrive qu’à moi ?

Cordialement :)

Édité par tleb

Équipe technique

Salut !

Alors j’ai regardé sur le Sentry et ça me semble lié à l’erreur nommée IntegrityError /forums/sujet/{topic_pk}/{topic_slug}/ qui est récurrente depuis plusieurs versions. À première vue, dans certains cas il semble y avoir deux entrées en base de données sur une table où on attend qu’une entrée par utilisateur et par sujet du forum, donc ça bug. Je vais essayer d’investiguer un peu plus et tenter quelques solutions. Par contre je n’ai pas d’idée de comment reproduire le bug à coup sûr.

+0 -0
Auteur du sujet

Tu as une trace d’erreur plus précise ? La view en question dans ton erreur est zds.forum.TopicPostsListView. Bizarre non ? C’est la view responsable de l’affichage d’un sujet. Elle ne fait pas la création de sujet ni le suivi de forum.

Ou alors il y a aussi des erreurs sur le suivi de sujets ?

Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte