Ubuntu - Après sortie de veille : panne de Wifi et de webcam

a marqué ce sujet comme résolu.

Bonjour à tous.

J’ai besoin d’une petite aide SVP (car ça fais quelques mois que j’essaie de résoudre ce problème, et sans succès pour le moment).

Sur mon PC portable MSI GS75 j’ai installé Ubuntu 20.04 (Kubuntu pour être + précis).

Quand je met en veille mon PC, à la sortie de veille il passe tout seul en mode avion. Et mon Wifi et mon bluetooth ne fonctionne plus, même ma Webcam ne fonctionne plus à la sortie de veille. Je suis obligé à chaque fois de redémarrer mon PC pour que tout re-fonctionnaire à nouveau.

PS : Je précise qu’avant j’avais Xubuntu 19.10, et que j’avais exactement le même problème.

Et je viens de remarquer que quand j’éteint, ou redémarre, ou allume mon PC, que j’ai ce message qui s’affiche brièvement dans un écran noir (qui ne reste pas longtemps noir) : iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS

Donc j’imagine qu’il y a un lien direct entre ce message et mon problème ?

Autres détails (résultats de commandes) :

sudo dmesg | grep WRDS :

[    9.044810] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS

cat /proc/acpi/wakeup :

# plein de ligne au dessus, puis :
HDAS      S4    *disabled  pci:0000:00:1f.3
CNVW      S4    *disabled  pci:0000:00:14.3
AWAC      S4    *enabled   platform:ACPI000E:00

sudo rfkill list (juste après d’avoir mis mon PC en veille) :

: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes

Alors qu’en tant normal (avant d’avoir mis mon PC en veille) j’avais ceci :

0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
1: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no

J’avais essayé de faire ceci (sans succès) :

# Décharger et recharger le module wifi :
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi
# Relancer network-manager :
sudo service network-manager restart

Autres détail : dans mon bios j’ai bien le secure boot de désactivé.

Avez-vous vu une idée SVP ?

Merci beaucoup.

Il doit y avoir un problème lorsqu’il récupère depuis la swap. Pourrais-tu envoyer les lignes de sudo dmesg qui correspondent entre le moment où la mise en veille commence et où ton ordinateur s’est rallumé ? Il devrait y avoir écrit si il y a eut des problèmes à redémarrer les cartes filles.

Il doit y avoir un problème lorsqu’il récupère depuis la swap. Pourrais-tu envoyer les lignes de sudo dmesg qui correspondent entre le moment où la mise en veille commence et où ton ordinateur s’est rallumé ? Il devrait y avoir écrit si il y a eut des problèmes à redémarrer les cartes filles.

Vanadiae

Ok merci beaucoup.

ça me retourne plein de lignes. Je t’ai copié celles qui je pense t’intéresse :

sudo dmesg - Avant veille (juste après avoir redémarré mon PC, quand la wifi marche) :

# plein de ligne en haut, puis (c'est ce qui nous interesse je pense) :
[    2.881607] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[    2.884871] input: MSI WMI hotkeys as /devices/virtual/input/input18
[    2.887844] iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
[    2.887845] iwlwifi 0000:00:14.3: Found debug configuration: 0
[    2.888094] iwlwifi 0000:00:14.3: loaded firmware version 46.6bf1df06.0 op_mode iwlmvm

# Encore des lignes en bas, puis :
[    2.950398] iwlwifi 0000:00:14.3: Detected Killer (R) Wireless-AC 1550i Wireless Network Adapter (9560NGW), REV=0x318
[    2.958592] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[    2.958975] iwlwifi 0000:00:14.3: Allocated 0x00400000 bytes for firmware monitor.
[    3.004208] iwlwifi 0000:00:14.3: base HW address: 48:f1:7f:c2:f7:45
[    3.023550] input: gpio-keys as /devices/platform/ACPI0011:00/gpio-keys.1.auto/input/input20
[    3.025128] usbcore: registered new interface driver uvcvideo
[    3.025130] USB Video Class driver (1.1.1)
[    3.033219] input: CUST0001:00 06CB:CDAD Mouse as /devices/pci0000:00/0000:00:15.2/i2c_designware.1/i2c-3/i2c-CUST0001:00/0018:06CB:CDAD.0001/input/input21
[    3.033342] input: CUST0001:00 06CB:CDAD Touchpad as /devices/pci0000:00/0000:00:15.2/i2c_designware.1/i2c-3/i2c-CUST0001:00/0018:06CB:CDAD.0001/input/input22
[    3.033447] hid-multitouch 0018:06CB:CDAD.0001: input,hidraw0: I2C HID v1.00 Mouse [CUST0001:00 06CB:CDAD] on i2c-CUST0001:00
[    3.049416] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    3.049642] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    3.073328] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    3.073908] thermal thermal_zone3: failed to read out thermal zone (-61)
[    3.077611] iwlwifi 0000:00:14.3 wlo1: renamed from wlan0

# Encore des lignes en bas :
[    8.486475] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    8.486477] Bluetooth: BNEP filters: protocol multicast
[    8.486480] Bluetooth: BNEP socket layer initialized
[    8.506618] NET: Registered protocol family 38
[    8.795941] alx 0000:03:00.0 enp3s0: NIC Up: 100 Mbps Full
[    8.796573] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready
[    8.806846] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[    8.922768] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[    8.988496] iwlwifi 0000:00:14.3: FW already configured (0) - re-configuring
[    8.997987] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
[    8.997994] fbcon: Taking over console
[    9.003201] Console: switching to colour frame buffer device 240x67
[   10.519313] Bluetooth: RFCOMM TTY layer initialized
[   10.519317] Bluetooth: RFCOMM socket layer initialized
[   10.519320] Bluetooth: RFCOMM ver 1.11

sudo dmesg - Après veille (sortie de veille, quand la wifi ne marche plus) :

# plein de ligne en haut, puis (c'est ce qui nous interesse je pense) :
 7737.932406] ACPI: Waking up from system sleep state S3
[ 7737.941563] ACPI: EC: interrupt unblocked
[ 7737.984011] ACPI: EC: event unblocked
[ 7737.986765] iwlwifi 0000:00:14.3: reporting RF_KILL (radio disabled)
# Encore des lignes en bas

Merci.

sudo dmesg - Après veille (sortie de veille, quand la wifi ne marche plus) :

# plain de ligne en haut, puis (c'est ce qui nous interesse je pense) :
 7737.932406] ACPI: Waking up from system sleep state S3
[ 7737.941563] ACPI: EC: interrupt unblocked
[ 7737.984011] ACPI: EC: event unblocked
[ 7737.986765] iwlwifi 0000:00:14.3: reporting RF_KILL (radio disabled)
# Encore des lignes en bas

stephweb

en fait, il faudrait mettre ton ordinateur en veille, attendre genre 3 minutes puis lancer dmesg avec —ctime, puis c’est toutes les lignes après les 3 minutes de pauses qu’il faudrait (donc à partir de la minute où tu relances l’ordinateur) pour pouvoir voir vraiment parce que là c’est pas grand chose comme informations. :)

en fait, il faudrait mettre ton ordinateur en veille, attendre genre 3 minutes puis lancer dmesg avec —ctime, puis c’est toutes les lignes après les 3 minutes de pauses qu’il faudrait (donc à partir de la minute où tu relances l’ordinateur) pour pouvoir voir vraiment parce que là c’est pas grand chose comme informations. :)

Vanadiae

Ok merci, mais je ne comprends pas trop (je suis passé sous Linux il y a seulement 4 mois, après 10 ans sous Windows, donc je ne suis pas expert. je ne connaissais même pas —ctime).

Je doit lancer cette commande : dmesg —ctime

juste après être sortie de veille (après avoir laissé durant 3 minutes mon PC en veille) ?

ok merci.

J’ai mis en veille à 16h16, et j’en suis sorti à 16h20 (mais il n’y a pas de ligne pour après 16h20) :

[dim. avril 26 16:16:59 2020] PM: suspend entry (deep)
[dim. avril 26 16:16:59 2020] Filesystems sync: 0.004 seconds
[dim. avril 26 16:16:59 2020] Freezing user space processes ... (elapsed 0.001 seconds) done.
[dim. avril 26 16:16:59 2020] OOM killer disabled.
[dim. avril 26 16:16:59 2020] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[dim. avril 26 16:16:59 2020] printk: Suspending console(s) (use no_console_suspend to debug)
[dim. avril 26 16:16:59 2020] psmouse serio1: Failed to disable mouse on isa0060/serio1
[dim. avril 26 16:17:01 2020] alx 0000:03:00.0 enp3s0: wol: ctrl=3, speed=A
[dim. avril 26 16:17:01 2020] ACPI: EC: interrupt blocked
[dim. avril 26 16:17:01 2020] ACPI: Preparing to enter system sleep state S3
[dim. avril 26 16:17:01 2020] ACPI: EC: event blocked
[dim. avril 26 16:17:01 2020] ACPI: EC: EC stopped
[dim. avril 26 16:17:01 2020] PM: Saving platform NVS memory
[dim. avril 26 16:17:01 2020] Disabling non-boot CPUs ...
[dim. avril 26 16:17:01 2020] IRQ 157: no longer affine to CPU1
[dim. avril 26 16:17:01 2020] smpboot: CPU 1 is now offline
[dim. avril 26 16:17:01 2020] IRQ 159: no longer affine to CPU2
[dim. avril 26 16:17:01 2020] smpboot: CPU 2 is now offline
[dim. avril 26 16:17:01 2020] IRQ 133: no longer affine to CPU3
[dim. avril 26 16:17:01 2020] IRQ 147: no longer affine to CPU3
[dim. avril 26 16:17:01 2020] smpboot: CPU 3 is now offline
[dim. avril 26 16:17:01 2020] IRQ 131: no longer affine to CPU4
[dim. avril 26 16:17:01 2020] IRQ 149: no longer affine to CPU4
[dim. avril 26 16:17:01 2020] smpboot: CPU 4 is now offline
[dim. avril 26 16:17:01 2020] IRQ 155: no longer affine to CPU5
[dim. avril 26 16:17:01 2020] smpboot: CPU 5 is now offline
[dim. avril 26 16:17:01 2020] IRQ 153: no longer affine to CPU6
[dim. avril 26 16:17:01 2020] smpboot: CPU 6 is now offline
[dim. avril 26 16:17:01 2020] IRQ 127: no longer affine to CPU7
[dim. avril 26 16:17:01 2020] IRQ 148: no longer affine to CPU7
[dim. avril 26 16:17:01 2020] smpboot: CPU 7 is now offline
[dim. avril 26 16:17:01 2020] smpboot: CPU 8 is now offline
[dim. avril 26 16:17:01 2020] smpboot: CPU 9 is now offline
[dim. avril 26 16:17:01 2020] smpboot: CPU 10 is now offline
[dim. avril 26 16:17:01 2020] smpboot: CPU 11 is now offline
[dim. avril 26 16:17:01 2020] ACPI: Low-level resume complete
[dim. avril 26 16:17:01 2020] ACPI: EC: EC started
[dim. avril 26 16:17:01 2020] PM: Restoring platform NVS memory
[dim. avril 26 16:17:01 2020] Enabling non-boot CPUs ...
[dim. avril 26 16:17:01 2020] x86: Booting SMP configuration:
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 1 APIC 0x2
[dim. avril 26 16:17:01 2020] microcode: sig=0x906ea, pf=0x20, revision=0x9a
[dim. avril 26 16:17:01 2020] microcode: updated to revision 0xca, date = 2019-10-03
[dim. avril 26 16:17:01 2020] intel_pstate: Disabling energy efficiency optimization
[dim. avril 26 16:17:01 2020] CPU1 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 2 APIC 0x4
[dim. avril 26 16:17:01 2020] CPU2 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 3 APIC 0x6
[dim. avril 26 16:17:01 2020] CPU3 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 4 APIC 0x8
[dim. avril 26 16:17:01 2020] CPU4 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 5 APIC 0xa
[dim. avril 26 16:17:01 2020] CPU5 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 6 APIC 0x1
[dim. avril 26 16:17:01 2020] microcode: sig=0x906ea, pf=0x20, revision=0xca
[dim. avril 26 16:17:01 2020] CPU6 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 7 APIC 0x3
[dim. avril 26 16:17:01 2020] CPU7 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 8 APIC 0x5
[dim. avril 26 16:17:01 2020] CPU8 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 9 APIC 0x7
[dim. avril 26 16:17:01 2020] CPU9 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 10 APIC 0x9
[dim. avril 26 16:17:01 2020] CPU10 is up
[dim. avril 26 16:17:01 2020] smpboot: Booting Node 0 Processor 11 APIC 0xb
[dim. avril 26 16:17:01 2020] CPU11 is up
[dim. avril 26 16:17:01 2020] ACPI: Waking up from system sleep state S3
[dim. avril 26 16:17:01 2020] ACPI: EC: interrupt unblocked
[dim. avril 26 16:17:01 2020] ACPI: EC: event unblocked
[dim. avril 26 16:17:01 2020] iwlwifi 0000:00:14.3: reporting RF_KILL (radio disabled)
[dim. avril 26 16:17:01 2020] nvme nvme0: Shutdown timeout set to 8 seconds
[dim. avril 26 16:17:01 2020] nvme nvme0: 12/0/0 default/read/poll queues
[dim. avril 26 16:17:02 2020] ata6: SATA link down (SStatus 4 SControl 300)
[dim. avril 26 16:17:02 2020] ata5: SATA link down (SStatus 4 SControl 300)
[dim. avril 26 16:17:04 2020] acpi LNXPOWER:05: Turning OFF
[dim. avril 26 16:17:04 2020] OOM killer enabled.
[dim. avril 26 16:17:04 2020] Restarting tasks ... 
[dim. avril 26 16:17:04 2020] usb 1-11: USB disconnect, device number 4
[dim. avril 26 16:17:04 2020] done.
[dim. avril 26 16:17:04 2020] thermal thermal_zone3: failed to read out thermal zone (-61)
[dim. avril 26 16:17:04 2020] usb 1-14: USB disconnect, device number 5
[dim. avril 26 16:17:04 2020] PM: suspend exit
[dim. avril 26 16:17:05 2020] alx 0000:03:00.0 enp3s0: NIC Up: 100 Mbps Full
[dim. avril 26 16:17:05 2020] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready

J’ai eu exactement le même problème sur mon ancien ordinateur portable, que je n’ai jamais réussi à résoudre. Une année et quelques après l’apparition du problème, ma carte wifi était morte. J’espère ne pas te porter la poisse :/

J’ai cherché j’ai pas retrouvé la référence précise. C’était un hp (pavillon je crois), que j’ai acheté en 2013.

lhp22

Ok, merci pour l’info.

ça ne me rassure pas que tu n’es jamais trouvé la solution. En plus mon PC n’est pas compatible avec le mode hibernation… donc faut que je trouve comment résoudre ce problème).

Logiquement ça ne devrai pas venir de la carte Wifi, vu qu’elle fonctionne (du moment que je ne passe pas mon PC en veille). Et à la sortie de veille ce n’est pas que mon wifi qui a ce problème, mais aussi le Webcam le Bluetooth (et peut êtres d’autres trucs que je n’ai pas encore remarqué).

As-tu essayé avec un autre système à base Linux (donc pas dérivé d’Ubuntu) pour voir si c’est du à ubuntu ? (tu peux juste essayé en live usb si tu veux, c’est plus simple)

Vanadiae

Non, j’ai essayé que des dérivés d’Ubuntu. Je voulais à tout prix Ubuntu histoire d’avoir les mêmes commandes que Debian (car sur mes serveurs web de prod j’ai Debian).

Je ne pense pas que je peux test mon problème en Live USB (en Live USB avec Ubuntu et ses dérivés je n’arrivais pas à mettre mon PC en veille, donc je ne pouvais pas test si je perdais le WiFi en sortie de veille).

Mais là, je me tâte à test Fedora ou Manjaro.

_Tu me conseillerais lequel ? (sachant que je suis dev PHP, et que mon PC me sert essentiellement à faire du dev web).

_Tu penses que mon problème peut venir de l’os ? Je pensais qu’un tel problème viendrait du nouveau Linux.

Si je te propose d’essayer un autre c-est parce qu’il arrive frequemment que quelque chose soit cassé chez ubuntu mais pas chez d’autres (pourtant même version des logiciels). Pour ma part j’utilise Fedora parce que c’est stable et on a rapidement les nouvelles versions des logiciels (et chez moi tous les composants de l’ordinateur ont fonctionnés directement sans avoir à installer quoi que ce soit). Je te conseille donc d’essayer celle là (c’est GNOME de base mais il existe des spins pour les autres). :D

Connectez-vous pour pouvoir poster un message.
Connexion

Pas encore membre ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte