Boutons "+1" "-1" qui se décalent au hover

a marqué ce sujet comme résolu.

Oh ben c’est cocasse ça !

Les boutons sont effectivement mal alignés de base mais se remettent en place une fois que l’on survole l’un d’entre eux

Alors je vois qu’au survol des boutons +1/-1 l’attribut title change (il y a un espace à la fin qui est enlevé).

Je vois aussi des margin à droite de la signature et à gauche de chaque bouton qui pourraient peut-être déclencher un rendu bizarre.

Il y a aussi un width: 0 sur les boutons qui me perturbe et n’a pas l’air de servir.

Deux choses a noter :

  • Je n’ai pas de problème sur mes propres messages.
  • Si je fait "Retour" et "Suivant" dans mon navigateur pour revenir à la page précédente et suivante, les boutons sont correctement alignés et le problème n’apparaît pas. Edit : En fait non, le problème est toujours là. Edit 2 : Ok, si je fait retour et revenir, les messages que j’ai survolés restent bien alignés, mais les autres sont toujours mal alignés.
+2 -0

Effectivement les boutons désactivés n’ont pas ce problème.

Le fait de revenir en arrière fait appel au cache du moteur de rendu, le rendu doit donc logiquement être le même et c’est a priori le cas.

Il y a des choses bizarres dans le CSS, je vais tenter des trucs quand j’aurai la motivation de relancer ma version locale.

Connectez-vous pour pouvoir poster un message.
Connexion

Pas encore membre ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte