Installer matplotlib

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

J'essaye en vain d'installer matplotlib pour Python 3 sur mon Fedora, mais j'obtiens cela :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
(MPF)[vincent@localhost matplotlib]$ git clone https://github.com/matplotlib/matplotlib
Cloning into 'matplotlib'...
remote: Counting objects: 94845, done.
remote: Compressing objects: 100% (322/322), done.
remote: Total 94845 (delta 225), reused 180 (delta 137)
Receiving objects: 100% (94845/94845), 194.25 MiB | 1.28 MiB/s, done.
Resolving deltas: 100% (69037/69037), done.
Checking connectivity... done
Checking out files: 100% (3062/3062), done.
(MPF)[vincent@localhost matplotlib]$ cd matplotlib/
(MPF)[vincent@localhost matplotlib]$ python3 setup.py build
============================================================================
Edit setup.cfg to change the build options

BUILDING MATPLOTLIB
            matplotlib: yes [1.5.x]
                python: yes [3.3.2 (default, Jun 30 2014, 17:19:32)  [GCC
                        4.8.3 20140624 (Red Hat 4.8.3-1)]]
              platform: yes [linux]

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [version 1.8.0]
                   six: yes [six was not found.]
              dateutil: yes [dateutil was not found. It is required for date
                        axis support. pip/easy_install may attempt to
                        install it after matplotlib.]
                  pytz: yes [pytz was not found. pip will attempt to install
                        it after matplotlib.]
               tornado: yes [tornado was not found. It is required for the
                        WebAgg backend. pip/easy_install may attempt to
                        install it after matplotlib.]
             pyparsing: yes [pyparsing was not found. It is required for
                        mathtext support. pip/easy_install may attempt to
                        install it after matplotlib.]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: yes [version 2.5.0]
                   png: yes [version 1.6.3]
                 qhull: yes [pkg-config information for 'qhull' could not be
                        found. Using local copy.]

OPTIONAL SUBPACKAGES
           sample_data: yes [installing]
              toolkits: yes [installing]
                 tests: yes [nose 0.11.1 or later is required to run the
                        matplotlib test suite.  pip/easy_install may attempt
                        to install it after matplotlib. / using
                        unittest.mock]
        toolkits_tests: yes [nose 0.11.1 or later is required to run the
                        matplotlib test suite.  pip/easy_install may attempt
                        to install it after matplotlib. / using
                        unittest.mock]

OPTIONAL BACKEND EXTENSIONS
                macosx: no  [Mac OS-X only]
                qt5agg: yes [installing, Qt: 5.3.1, PyQt: 5.3.1]
Traceback (most recent call last):
  File "setup.py", line 153, in <module>
    result = package.check()
  File "/home/vincent/Documents/matplotlib/matplotlib/setupext.py", line 503, in check
    additional_info = self.check_requirements()
  File "/home/vincent/Documents/matplotlib/matplotlib/setupext.py", line 1944, in check_requirements
    msg = res.get(timeout=10)[0]
  File "/usr/lib/python3.3/multiprocessing/pool.py", line 564, in get
    raise self._value
RuntimeError: the sip module implements API v11.0 to v11.1 but the PyQt4.QtCore module requires API v10.0

La même erreur est déclenchée si je passe par pip. J'ai donc essayé d'installer une version antérieure de SIP (la 4.14.4, avec laquelle PyQt4 fonctionne) mais quand je relance l'installation, il me dit que PyQt5 nécessite une API plus récente de SIP.

Comment puis-je remédier à ce problème ?

Merci !

Édité par firm1

+0 -0
Auteur du sujet

Effectivement, c'est plus simple ainsi. x)

Merci beaucoup !

Aurais-tu une idée de comment le problème a été réglé, de la raison pour laquelle ça fonctionne avec yum et pas avec pip ?

+0 -0
Staff

Je vois deux possibilités, soit la version (1.3 dans les dépôts, 1.4 pour pip/git), soit ça tente d'installer matplotlib-qt4 et *-qt5 et se plante sur un conflit de version.

Je penche pour la deuxième solution, car d'un côté on a qt5agg: yes [installing, Qt: 5.3.1, PyQt: 5.3.1], et de l'autre, il tente quelque chose avec Qt4 (the sip module implements API v11.0 to v11.1 but the PyQt4.QtCore module requires API v10.0). Il doit y avoir une option de compilation pour ne pas prendre toute les interfaces graphiques disponibles mais seulement qt5/tkinter.

Hier, dans le parc, j'ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte