Il détecte une manette alors qu'il n'y en a pas..

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous !
J'ai profité des soldes sur Steam pour m'acheter plusieurs jeux. Seulement voilà, TOUS les jeux que j'ai acheté ont un bug vraiment gênant, ils détectent tous une manette, ce qui fait que je dois appuyez sur [A] et [B] et que je personnage va tout seul vers la gauche (je ne touche vraiment à rien !).

Quelqu'un a déjà eu ce bug ? Si oui, comment le résoudre ?
Merci de votre aide! :)

Mon projet : OpenPlane, un utilitaire en Java pour les pilotes, les vrais !

+0 -0

moi, je partirais du principe que si tous les jeux on le même problème, c'est que ce problème à + de chance de venir de la plateforme…c'est quoi ta plateforme de jeux (console/ordi/freebox…)

Vous m’avez reproché de penser que j’avais toujours raison. Et je me suis rendu compte que vous aviez raison.... Mais allez savoir si j’ai raison !

+0 -0
Auteur du sujet

Oh oui mince j'ai oublié de préciser ça ! Je suis sous ArchLinux. Mais enfaite c'est ma souris Bluetooth qu'il détecte comme une manette de Xbox 360 ! Et je ne sais pas du tout comment résoudre ce problème :/

Mon projet : OpenPlane, un utilitaire en Java pour les pilotes, les vrais !

+0 -0

ha bah… peut-être mieux configurer ta souris dans arch linux, histoire que l'OS l'identifie pas comme une manette xbox…

je saurais pas le faire, mais je parierais qu'il faut aller bidouiller dans tes fichiers de config. ce qui peut aller dans ceux de x11 (notamment /etc/X11/xorg.conf.d) , dans ceux de ta souris à proprement parler, bref je sais pas trop, mais je te donne des axes de recherche avant que quelqu'un de confirmé en linux passe.

Oui. Non. Attends, je regarde mieux et je te dis.

+0 -0

L'analyse de remace me semble bonne. Je suis très très mauvais en conf Xorg, mais après quelques recherches peut-être que ceci va t'aider:

1
2
3
4
5
6
7
Section "InputClass"
        Identifier "Souris bluetooth comme il faut"
        MatchProduct "truc" # tu n'es pas obligé de tout mettre,
        MatchVendor "bazar" # je mets les options qui semblent utiles
        MatchPnPID "machin" # pour essayer de chopper ta souris
        Option "CorePointer" # ou Option "Floating" "off"
EndSection

Si tu as une conf modulaire, mettre ceci dans /etc/X11/xorg.conf.d/40-perso.conf peut être une bonne idée.

Néanmoins, je ne suis pas sûr que ça va marcher. Autre solution : désactiver toutes les manettes.

Si conf modulaire, c'est le fichier /etc/X11/xorg.conf.d/10-evdev.conf qu'il faut modifier s'il existe.

1
2
3
4
5
6
Section "InputClass"
        Identifier "desactiver les manettes"
        MatchIsJoystick "on"
        Driver "evdev"
        Option "Ignore" "on"
EndSection

C'est dans le cas où ta souris serait reconnue comme souris et manette (ce qui est théoriquement possible il me semble). Le 2 sont peut-être à combiner.

There is no place like /home.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte