Problème lm35

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour.

J'ai un petit soucis avec mon LM35, la sonde de température.

J'ai fais un montage avec un lcd pour afficher les températures. Mais les résultats ne sont pas identique avec et sans le lcd et même avec et sans le rétroéclairage du lcd.

Comment puis-je faire pour stabilisé les résultats obtenu?

Merci!

+0 -0
Auteur du sujet

schema J’espère que mon upload fonctionne ^^

Donc la si j'enlève le rétroéclairage ou même le LCD, la température diminue…

Merci :)

Édité par Nay

+0 -0

Oui l'upload a fonctionné.

Il serait bien de donner aussi la référence de l'écran même si ce n'est pas l'élément principal.

Enfin quand tu dis que la température change ou même diminue, peux-tu donner des valeurs ? Parce que le rétroéclairage allumé ca va produire de la chaleur, tout comme allumer l'écran LCD. Sauf que la variation de température sera plutôt faible (aller on va dire autour de 1°C max). Alors que si tu as une grosse variation de température, la cause peut être différente.

+0 -0

j'actualise les mesures toutes les secondes avec un changement +/- 1° à chaque fois

Ca c'est surement du a la facon dont sont faites les mesures. Ca peut se regler. Le plus genant c'est le drop de 5 degres quand tu branches le LCD… Tu as un voltmetre ? Tu pourrais mesurer la tension sur ta ligne d'alimentation sur ta breadboard avant et apres avoir branche le LCD ?

ZdS, le best du Zeste ! Tuto Arduino, blog, etc

+0 -0
Auteur du sujet

Donc…

j'ai nettoyé mon montage de toute les pattes des composants superflux.

A l'heure actuelle: Avec LCD: entre 24,81 et 23,83. Sans: 22,86

mais dès que ça bouge, ça fluctue énormément genre là, je suis à 30,16....

La breadboard peut elle être de mauvaise qualité? Ou les cables??

+0 -0

Cette réponse a aidé l'auteur du sujet

mais dès que ça bouge

Des que tu gigotes la carte ?

La breadboard peut elle être de mauvaise qualité? Ou les cables??

Oui. J'ai connu une breadboard qui me faisait des rebonds dans tout les sens tellement les contacts étaient mauvais. Tu peux toujours essayer de changer d'emplacement sur la breadboard…

ZdS, le best du Zeste ! Tuto Arduino, blog, etc

+0 -0
Auteur du sujet

mais dès que ça bouge

Des que tu gigotes la carte ?

Oui exactement, même un tout petit peu, genre je la soulève de quelques centimètre et la repose.

La breadboard peut elle être de mauvaise qualité? Ou les cables??

Oui. J'ai connu une breadboard qui me faisait des rebonds dans tout les sens tellement les contacts étaient mauvais. Tu peux toujours essayer de changer d'emplacement sur la breadboard…

Eskimon

Ah… ça peut être ça alors! je vais voir pour en prendre une nouvelle alors! peut-être que ça va changé quelques chose

EDIT: la par contre ça c'est plutôt bien stabilisé, je sais pas pourquoi mais ça fluctue plus du tout…

Édité par Nay

+0 -0

Ah… ça peut être ça alors! je vais voir pour en prendre une nouvelle alors! peut-être que ça va changé quelques chose

Protip: l'apparence de la breadboard ne compte pas. Chez moi j'en ai une qui brille tellement elle est neuve et bourrée de faux contact et une toute terne sans couleur qui est nickel et fiable.

EDIT: la par contre ça c'est plutôt bien stabilisé, je sais pas pourquoi mais ça fluctue plus du tout…

Ouai donc tu as bien des faux contacts qui traînent et pourrissent tes mesures/tensions

Édité par Eskimon

ZdS, le best du Zeste ! Tuto Arduino, blog, etc

+0 -0
Auteur du sujet

Ah… ça peut être ça alors! je vais voir pour en prendre une nouvelle alors! peut-être que ça va changé quelques chose

Protip: l'apparence de la breadboard ne compte pas. Chez moi j'en ai une qui brille tellement elle est neuve et bourrée de faux contact et une toute terne sans couleur qui est nickel et fiable.

plutôt mettre un peu le prix pour la qualité?

EDIT: la par contre ça c'est plutôt bien stabilisé, je sais pas pourquoi mais ça fluctue plus du tout…

Ouai donc tu as bien des faux contacts qui traînent et pourrissent tes mesures/tensions

Eskimon

Oui en effet! bon au moins je sais ce qui cloche.

Par contre, pour corrigé la chaleur émise par le LCD, je mesure avec et sans et j'enlève le résultat dans mon calcul?

En tous cas merci pour tout! une grande aide!!!

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte