betise avec sudo

pour ceux qui aurait fait un chmod 777 de tous le système, ou aurait modifier les permissions dans /usr/bin/sudo

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Problème en cours de résolution :)

salut à tous,

tout à l'heure en voulant modifier les permissions d'un fichier j'ai appuyé un peu rapidement sur la touche entrée du clavier.

La commande était la suivante: sudo chmod -R 777 /

Le problème c'est que ca a tout bazardé et que maintenant tout doit avoir toutes les permissions non ?

Comment je peux faire pour régler le problème car quand je tape sudo quelquechose ca me mets

sudo: /usr/bin/sudo doit être la propriété du uid 0 et avoir le bit setuid mis

Édité par albert733

+0 -0

Cette réponse a aidé l'auteur du sujet

Bonjour

Je crains que ça soit difficile à réparer. Il faudrait pour cela réussir à remmettre un par un les bon droits aux bon fichiers et ça me semble franchement pas gagné :(

La meilleure solution est peut-être de récupérer tes données en démarrant sur un live-cd et de tout ré-installer.

+1 -0
Auteur du sujet

entre temps j'ai trouvé ce lien je vais donc essayer est-ce que le changement de ces droits aura un impact sur mon ordinateur ?

EDIT: J'ai donc suivi le lien j'ai donc une petite méthode à donner qui a l'air de marcher:

  • démarrer en mode recovery

  • choisissez ensuite root pour passer en mode commande

Image utilisateur

  • taper la commande:
1
mount -o remount,rw /

qui va permettre de passer en mode écriture

  • puis taper la commande:
1
chmod 4755 /usr/bin/sudo

qui redonne les permissions normales au root

Avec 4755 on obtient l'erreur: sudo: /var/lib/sudo writable by non-owner (040777), should be mode 0700

Avec 0700 ca marche pas non plus car on a pas les permissions requises donc à vous de voir

  • ensuite quitter votre terminal:
1
exit
  • vous pouvez ensuite reprendre une utilisation "normale" de votre ordinateur en choisissant l'option resume du mode recovery

J'ai bien mis normal entre guillemets car la commande chmod -R 777 / a obligatoirement abîmé votre ordinateur et il est donc conseillé de réinstaller le système (profitez-en pour faire une sauvegarde et passez à la version supérieure :))

Édité par albert733

+0 -0

Cette réponse a aidé l'auteur du sujet

Pour les permissions, quand tu ne sais pas précisément quoi mettre, dans le doute tu peux déjà faire un 755 root root sur les dossiers systèmes (sauf /tmp).

Après, une chose à faire dès maintenant, c'est un 644 sur /etc/passwd et /etc/group, ainsi qu'un 600 sur /etc/shadow et /etc/gshadow, afin de conserver secret les infos sur les mdp, et que personne ne vienne mettre le bazar dans les utilisateurs et groupes.

There is no place like /home.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte