Toujours une erreur bad gateway

L'auteur de ce sujet a trouvé une solution à son problème.
Staff
Auteur du sujet

Bonjour,

j'essaie actuellement de mettre en place un serveur subsonic sur mon serveur dédié parce que j'ai besoin d'accéder à mes playlists d'un peu partout.

J'ai donc créé un sous domaine subsonic.francoisdambrine.me et j'ai installé le serveur subsonic avec nginx en suivant les différents tutos dispos sur le web. sauf que voilà, quand je vais à l'adresse que je vous ai donnée, je n'ai qu'une erreur 502.

Voici le fichier /etc/default/subsonic

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#
# This is the configuration file for the Subsonic service
# (/etc/init.d/subsonic)
#
# To change the startup parameters of Subsonic, modify
# the SUBSONIC_ARGS variable below.
#
# Type "subsonic --help" on the command line to read an
# explanation of the different options.
#
# For example, to specify that Subsonic should use port 80 (for http)
# and 443 (for https), and use a Java memory heap size of 200 MB, use
# the following:
#
# SUBSONIC_ARGS="--port=4040 --max-memory=200"

# SUBSONIC_ARGS="--max-memory=150 --port=8443"
SUBSONIC_ARGS="--context-path=/ --port=8082 --https-port=0 --max-memory=300"

# The user which should run the Subsonic process. Default "root".
# Note that non-root users are by default not allowed to use ports
# below 1024. Also make sure to grant the user write permissions in
# the music directories, otherwise changing album art and tags will fail.

SUBSONIC_USER=www-data

Et ensuite le fichier de conf nginx /etc/nginx/sites-enabled/subsonic.francoisdambrine.me

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
        listen  80;
#        listen  443;
        server_name subsonic.francoisdambrine.me;

        location / {
                proxy_pass http://localhost:8082;
                proxy_redirect  off;
                proxy_set_header        Host            $host;
                proxy_set_header        X-Real-IP       $remote_addr;
                proxy_set_header        X-Forwarded-For $proxy_add_x_forwarded_for;
        }
   }

Savez-vous ce qui cause le problème?

Édité par artragis

+0 -0
Staff
Auteur du sujet

J'ai réussi à le faire. par exemple un fois que je suis loggé, je suis sur http://subsonic.francoisdambrine.me/index.view.

En fait je me cassais pas mal les dents dessus parce que certains ports sont mal redirigés.

Ensuite j'ai tenté sur le 8080 mais comme mon dédié est coloué avec deux autres personnes, c'est un jira qui se trouve sur ce port.

En fait le moment "clé" de la config a été quand j'ai trouvé une source qui disait qu'il fallait mettre dans /etc/default/subsonic le paramètre --context-path=/. Ensuite tout semble fonctionner.

+1 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte