Annotations pour validation

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Salut,

Validateur récemment en poste, je me suis aperçu que j'aimais bien utiliser les fonctionnalités d'annotation/commentaire des traitements de texte comme Word ou les équivalents libre pour faire des remarques. Il existe bien des solutions sur le net mais cela nécessite de s'inscrire et on ne sait pas trop où vont les données (sachant que certains site disent clairement qu'ils exploitent les données, lesquelles, comment et pourquoi, on ne sait pas), ce qui pour des articles et tutoriel n'est pas absolument critique mais c'est toujours préférable de pouvoir faire quelque chose sur le site originel plutôt que de dépendre de sites tiers.

D'autre part ces sites demandent en général une inscription ce qui peut être embêtant pour mettre une uniformisation. Après avoir longuement chercher une solution en ligne du style Framapad mais avec une gestion de commentaire, je suis tombé sur une extension Javascript open-source : Annotator

Le plugin semble relativement mature et utilisé sur de nombre plateformes de collaboration en ligne, notamment par des sites plus ou moins proches de ZdS, voir le Showcase.

Il y a bien la bêta des tutos qui permet de faire des remarques, mais quand celle-ci sont nombreuses, il peut être difficile de bien se faire comprendre en citant un morceau de texte dans un post de forum ou en MP, et en faisant une petite remarque, surtout sur de gros tutos où il faut donner la partie.

Dans un premier temps je verrais bien ce plugin en disponibilité seulement pour les validateurs vu que les commentaires sur les bêtas des tutos concernent principalement soit des fautes d'orthographe, soit la philosophie ou l'axe pris par un tuto et on discute peu du contenu détaillé.

+7 -0

Je me permet de rajouter un petit point technique: les annotations sont sauvegardé par une API REST, et comme on a beaucoup de chance, il y'a un projet GitHub avec un backend en Flask (autre framework Python).

Y'a aussi un point bizarre, il parle d'une version 2 qui casse avec l'existant la version 1.1.2 . Les changements de la version 2 rendent incompatible les plugins et le module auth, ne marche pas et ce module est indispensable. Soit on utilise l'ancienne version 1.1.2 ou on attend pour utiliser la version 2.

Sinon en tant qu'utilisateur je trouve ça vraiment une bonne idée, je pense que ça peut apporter quelque chose pour discuter entre auteurs et pour reporter une erreur.

Édité par anonyme

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte