configuration double ecran

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour a tous,

je viens juste de recevoir mon second ecran de pc je l'ai donc branché et j'ai recherché comment le configurer mais je suis tombé sur plein de methode comme modifier xorg.conf ou avec xrandr, etc… J'aimerais donc savoir quelle technique est la mieux a utiliser.

merci d'avance de votre aide :)

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0

Tu peux t'en sortir avec xrandr en console sinon, de cette façon :

  • xrandr --output lasortie --auto permet d'allumer la sortie correspondante avec le mode le plus adapté
  • xrandr --output lasortie --mode 1980x1024 permet d'allumer la sortie correspondante avec le mode 1980x1024
  • xrandr --output lasortie --left-of lautresortie permet de mettre la sortie lasortie à gauche de lautresortie. Tu as aussi --right-of, --above, --below.
  • xrandr sans options t'affichera la liste des sorties et leurs modes disponibles.
+0 -0

Est-ce que ça fonctionne en faisant `./~/.xprofilè déjà ?

Si oui, quel Desktop Manager est-ce que tu utilises ? (Slim, GDM, KDM, lightdm, … ?)

edit : tu as bien compris que les lignes avec une dièse au début ne sont pas exécutées ? (on ne sait jamais, ça peut faire gagner du temps s'il y a confusion)

Édité par unidan

+0 -0
Auteur du sujet

Est-ce que ça fonctionne en faisant `./~/.xprofilè déjà ?

unidan

Yep sa fonctionne

Si oui, quel Desktop Manager est-ce que tu utilises ? (Slim, GDM, KDM, lightdm, … ?)

unidan

lightdm avec xfce

edit : tu as bien compris que les lignes avec une dièse au début ne sont pas exécutées ? (on ne sait jamais, ça peut faire gagner du temps s'il y a confusion)

unidan

Oui je le sais que les dieses invoquent des commentaires

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0
Auteur du sujet

Tu as essayé en mettant la configuration dans les fichiers xorg plutôt ?

unidan

Non

Ca marche dès le demarrage du serveur au moins !

unidan

Bah les 2 ecrans marchent mais il affichent la meme chose

Du coup pour l'instant j'ai mis la commande dans le demmarage de xfce mais c'est bancale comme technique

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
Section "Monitor"
        Identifier      "foo"
        ....
EndSection

Section "Monitor"
        Identifier      "bar"

        #Options LeftOf, RightOf, Above, Below specify monitors' relative position

        Option "LeftOf"  "foo"
        ....

Il ne manquerait pas ce genre de code dans ta configuration ?

+0 -0
Auteur du sujet

Il ne manquerait pas ce genre de code dans ta configuration ?

unidan

Bah pour l'intant je n'ai pas de xorg.conf mais en fait il y a juste ca (en dessous) que je ne comprends pas :

1
2
3
4
5
6
Monitor       "foo"
        DefaultDepth  24
        SubSection "Display"
                Depth          24
                Modes         "1280x1024"  "1024x768"   "640x480"
        EndSubSection

Et l'identifier du moniteur c'est au pif ?

Édité par LudoBike

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0

Non, c'est toi qui les choisi avec la section device :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
Section "Device"
        Identifier      "Intel 945G "
        Driver         "intel"

        # Using the name of the output defined by the video driver plus the identifier of a
        #     monitor section, one associates a monitor section with an output by adding an
        #     option to the Device section in the following format:
        #     Option "Monitor-outputname" "monitor ID"

        Option          "monitor-VGA" "foo"
        Option          "monitor-LVDS" "bar"
        #Option         "monitor-TMDS-1" "dvi"
EndSection

Les noms du style monitor-LVDS correspondent à monitor- suffixé du nom de la sortie que l'on trouve avec la commande xrandr sans argument.

Une fois que tu as précisé quelle carte graphique était utilisée, avec quelle pilote, et quels écrans elle devait gérer, tu précises le mode que tu veux pour chaque écran en créant une section par écran et en précisant à quel écran elle correspond via l'attribut Identifier.

En particulier, si tu ne précises pas comment l'écran doit être placé par rapport à l'écran principal, xorg va considérer que tu veux juste que ce soit un écran clone.

La sous-section Display est justement la section où tu définis les paramètres d'affichages de ton écran (fréquence, couleurs, modes par ordre de priorité, …).

+0 -0
Auteur du sujet

Ok donc sa c'est bon :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Section "Device"
    Identifier  "Video card"
    Driver      "nouveau"

    Option      "monitor-HDMI-1" "jam"
    Option      "monitor-DVI-D-1" "bon"
EndSection

Section "Monitor"
    Identifier  "jam"
EndSection

Section "Monitor"
    Identifier  "bon"
    Option      "RightOf" "jam"
EndSection

Section "Screen"
    Identifier  "Default screen"
    Device      "Video card"
    Monitor     "jam"
    DefaultDepth    24
    Subsection "Display"
           Depth    24
           Modes    "1920x1080"  "1280x1024"  "1024x768"
    EndSubsection
    Monitor     "bon"
    DefaultDepth    21
    Subsection "Display"
           Depth    21
           Modes    "1920x1080"  "1280x1024"  "1024x768"
    EndSubsection
EndSection

Depth c'est bien la diagonale de l'écran ?

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0

Non, Depth est la profondeur de couleur (le nombre de bit utilisé pour représenter les couleurs), donc il faut plutot lui donner la valeur 24.

Tu n'as pas besoin de préciser la diagonale d'écran, seulement la résolution, et c'est l'écran qui va s'adapter à ce que tu lui envoies s'il supporte le mode.

Tu as beaucoup d'infos ici aussi : https://wiki.archlinux.org/index.php/Xorg

Sinon le reste me parait bon !

+0 -0
Auteur du sujet

Bah en fait le fichier marche sur lightdm et sur la session de ma mere mais pas sur la mienne donc je pense qu'il y a un fichier dans mon ~ qu'il faut supprimer mais je ne sais pas lequel

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0

Le fichier xorg ? est-ce que tu as une carte différente des autres pc ? c'est sur le même pc ? Peux tu poster le fichier /var/log/Xorg.0.log après avoir démarré sur ta session ? (tu le copies quelque part avec un des tty).

+0 -0
Auteur du sujet

Le fichier xorg ? est-ce que tu as une carte différente des autres pc ? c'est sur le même pc ?

unidan

C'est sur le meme pc

sinon sur Xorg.0.log j'ai trouvé cette ligne

1
2
3
   338  [  1055.606] (II) NOUVEAU(0): RandR 1.2 enabled, ignore the following RandR disabled message.
   339  [  1055.606] (WW) NOUVEAU(0): Option "RightOf" is not used
   340  [  1055.606] (--) RandR disabled

le fichier en entier est ici

tu veux peut etre celui d'une autre session ?

« La Nature est un livre écrit en langage mathématique », Galilée

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte