Connexion au site impossible

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

je ne parviens plus à afficher ZdS depuis tout à l'heure. J'ai une erreur de certification .

Cette connexion n'est pas certifiée

Vous avez demandé à Firefox de se connecter de manière sécurisée à zestedesavoir.com, mais nous ne pouvons pas confirmer que votre connexion est sécurisée.

Normalement, lorsque vous essayez de vous connecter de manière sécurisée, les sites présentent une identification certifiée pour prouver que vous vous trouvez à la bonne adresse. Cependant, l'identité de ce site ne peut pas être vérifiée.

Que dois-je faire ?

Si vous vous connectez habituellement à ce site sans problème, cette erreur peut signifier que quelqu'un essaie d'usurper l'identité de ce site et vous ne devriez pas continuer.

Ce site a recours à HTTP Strict Transport Security (HSTS) pour indiquer à Firefox de n'établir qu'une connexion sécurisée. Ainsi il n'est pas possible d'ajouter d'exception pour ce certificat.

Détails techniques

zestedesavoir.com uses an invalid security certificate.

The certificate is not trusted because it is self-signed.

(Error code: sec_error_unknown_issuer)

Ça ne me le fait qu'avec Firefox (40.0, sous linux) (j'écris depuis rekonq, navigateur basé sur QtWebKit). Il n'est pas possible d'accepter le certificat sous firefox (mais possible sous rekonq, sans quoi je n'aurai pas pu me connecter, puisqu'il considère lui aussi le certificat comme invalide).

L'adresse est https://zestedesavoir.com/. Le passage en http ou en www.zeste renvoie vers la même page.

Merci.

Hier, dans le parc, j'ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0
Auteur du sujet

Je viens de voir le message sur la page d'accueil. (IMPORTANT Suite à un problème, le HTTPS est autosigné. Les données du 18/08 entre 3h du matin et minuit, heure de Paris, sont perdues. Recherche HS. Perturbations à prévoir.) Je ne savait pas qu'il n'étais pas affiché en non connecté.

Bref, le truc lourd est que le certificat auto signé marche mal avec Firefox.

Édité par Gabbro

Hier, dans le parc, j'ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0

Salut !
Une solution qui a marché pour moi : désactiver HSTS.

Dans about:config, rajouter l'entrée "test.currentTimeOffsetSeconds" et assigner la valeur "11491200".
Un coup de suppression de l'historique récent (CTRL+MAJ+DEL), et le tour est joué, on retrouve la partie "Je comprends les risques" sur a page d'erreur afin d'accepter le certificat.

+0 -0
Staff

Salut,

Pour Firefox, je suis parvenu à corriger le soucis en supprimant les anciens certificats (Options > Avancé > Certificats > Afficher les certificats et supprimez les entrées en rapport avec Zds dans les onglets Serveurs et Autorités), en vidant le cache et les données hors connexions (Options > Avancé > Réseau) et en effacant les préférences de sites (Options > Vie privée > Utiliser les paramètres personnalisés pour l'historique > Paramètres > Cochez préférences de sites). Une fois Firefox redémarré, il va vous demander d'inscrire deux exceptions pour les domaines www.zestedesavoir.com et zestedesavoir.com, après quoi cela fonctionnera comme sur des roulettes (testé avec Iceweasel 31). ;)

Édité par Taurre

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte