Erreur Apache 2

impossible de relancer apache

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour, j'ai suivis cette tuto sur Apache 2 et les répertoir de travail : doc.ubuntu-fr.org et quand je relance apache 2 j'obtien l'erreur suivante :

1
Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.

voilà mon vhost:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
    <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        <RequireAny>
            Require ip 127.0.0.1
            Require ip 192.168.1
        </RequireAny>
    </Directory>
    ## ZONE PUBLIQUE
    Alias /public /media/pi/F6C4-AF15/dev/public
    <Directory /media/pi/F6C4-AF15/dev/public>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require all granted
    </Directory>

    ## ZONE PRIVEE
    Alias /private /media/pi/F6C4-AF15/dev/private
    <Directory /media/pi/F6C4-AF15/dev/private>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        <RequireAny>
            Require ip 127.0.0.1             # Local
            Require ip 192.168.1             # Réseau
            Require host .w3.org             # W3C
            Require host sandbox.paypal.com  # Paypal
        </RequireAny>
    </Directory>    
    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Merci de votre aide !

Développeur php depuis 10 ans. Si vous penser que mon message est agressif, je vous rassure ce n'est pas le cas ou alors je …

+0 -0
Auteur du sujet

Il aurait fallu le retour des logs via journalctl, ça donnerait plus d'indications. Là on ne sait absolument rien de l'erreur.

Grimur

Si tu veux les logs voilà :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
[Sat Oct 10 16:53:34.058402 2015] [mpm_event:notice] [pid 2399:tid 1996386304] AH00491: caught SIGTERM, shutting down
[Sat Oct 10 16:53:34.508513 2015] [mpm_prefork:notice] [pid 5245] AH00163: Apache/2.4.10 (Raspbian) configured -- resuming normal operations
[Sat Oct 10 16:53:34.509092 2015] [core:notice] [pid 5245] AH00094: Command line: '/usr/sbin/apache2'
[Sat Oct 10 16:53:37.848558 2015] [mpm_prefork:notice] [pid 5245] AH00169: caught SIGTERM, shutting down
[Sat Oct 10 16:53:38.569212 2015] [mpm_prefork:notice] [pid 5345] AH00163: Apache/2.4.10 (Raspbian) configured -- resuming normal operations
[Sat Oct 10 16:53:38.569548 2015] [core:notice] [pid 5345] AH00094: Command line: '/usr/sbin/apache2'
[Sat Oct 10 17:04:00.746330 2015] [mpm_prefork:notice] [pid 5345] AH00169: caught SIGTERM, shutting down
[Sat Oct 10 17:04:02.425670 2015] [mpm_prefork:notice] [pid 14262] AH00163: Apache/2.4.10 (Raspbian) configured -- resuming normal operations
[Sat Oct 10 17:04:02.426074 2015] [core:notice] [pid 14262] AH00094: Command line: '/usr/sbin/apache2'
[Sat Oct 10 17:53:46.256767 2015] [mpm_prefork:notice] [pid 14262] AH00169: caught SIGTERM, shutting down
(défaitiste cette réponse, impossible n'est pas français)

Ce là dis c'est un problème de configs, si je supprimer les ligne rajouté à la base j'ai bien le contrôle sur Apache.

Développeur php depuis 10 ans. Si vous penser que mon message est agressif, je vous rassure ce n'est pas le cas ou alors je …

+0 -0

Cela dit c'est un problème de config, si je supprime les lignes rajoutées à la base j'ai bien le contrôle sur Apache

Et peux-tu détailler lesdites modifications ? Elles se résument à l'ajout de ce VH ou ça concerne d'autres points ? Sinon, as-tu tenté de :

  • le démarrer directement en ligne de commande (sudo httpd -X ?)
  • augmenter la verbosité (LogLevel)
  • commenter les lignes petit à petit pour essayer d'en trouver l'origine (en commençant par les *Require* ?)

Édité par vibrice

+0 -0
Auteur du sujet

Dés fois je me pose des questions …
voilà ce que j'ai rajouté dans VH :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
<Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        <RequireAny>
            Require ip 127.0.0.1
            Require ip 192.168.1
        </RequireAny>
    </Directory>
    ## ZONE PUBLIQUE
    Alias /public /media/pi/F6C4-AF15/dev/public
    <Directory /media/pi/F6C4-AF15/dev/public>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require all granted
    </Directory>

    ## ZONE PRIVEE
    Alias /private /media/pi/F6C4-AF15/dev/private
    <Directory /media/pi/F6C4-AF15/dev/private>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        <RequireAny>
            Require ip 127.0.0.1             # Local
            Require ip 192.168.1             # Réseau
            Require host .w3.org             # W3C
            Require host sandbox.paypal.com  # Paypal
        </RequireAny>
    </Directory>    

le démarrer directement en ligne de commande (sudo httpd -X ?)

Non je n'essaye pas d'outrepasser des fonctions unix faite pour ça : j'utilise service !

augmenter la verbosité (LogLevel)

non plus, car je ne sais pas faire …

commenter les lignes petit à petit pour essayer d'en trouver l'origine (en commençant par les Require ?)

J'avoue que non, mais tu as une idée derrière la tête ? Je fais confiance en ce site qui est supposé suivre les indications et recommandation officiel d'apache.

Je testerait ce dernière point dès que j'aurais du temps… En espérant avoir plus de réponses!

Édité par darkiron

Développeur php depuis 10 ans. Si vous penser que mon message est agressif, je vous rassure ce n'est pas le cas ou alors je …

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte