Formattage d'adresse web qui casse les liens

L'auteur de ce sujet a trouvé une solution à son problème.
Staff
Auteur du sujet

Bonjour,

La présence d'un tilde (~) semble casser les liens :

lien cassé (http://www-cs-students.stanford.edu/~amitp/game-programming/polygon-map-generation/) mène vers une 404. Copiez l'adresse du lien précédant (touche gauche de la souris, copier l'adresse du lien), vous verrez "http://www-cs-students.stanford.edu/%7Eamitp/game-programming/polygon-map-generation/", avec un pas beau %7E. Le vrai lien avec un ~ marche.

Édit : Cependant, ça semble ne le faire qu'avec ce lien.

Autre exemple avec un tilde, mais qui marche.

3ème exemple, qui marche aussi.

Il est possible que ce soit lié au site pointé plus qu'à ZdS.

Bonne journée.

Édité par Gabbro

Hier, dans le parc, j'ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0

Le premier lien fonctionne chez moi. Je suis sous Firefox (ArchLinux). Mais effectivement, lorsque je le copie, j'ai un %7E à la place du tilde, mais FF s'en accommode.

Édité par Vayel

+0 -0
Staff
Auteur du sujet

Le premier lien ne fonctionne pas chez moi alors que je suis sous Firefox 41 (Opensuse). Mais après vérification, il marche sous Rekonq ou konqueror (moteur webkit et KHtml).

Hier, dans le parc, j'ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0

J'ai l'impression que tout cela est lié à ce bug.

En réalité le parseur markdown actuel échappe les liens écrits avec la syntaxe [lien](url), donc si tu mets http://www-cs-students.stanford.edu/%7Eamitp/game-programming/polygon-map-generation/, il va à nouveau échapper le % est généré une URL incorrecte…

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte