gotoAndPlay ne decale pas la bande sonore ?

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous,

J'ai petit soucis avec Flash, en AS 3.0. j'essaye de synchroniser une longue bande sonore avec des animations, mais à chaque fois je dois rejouer tout le swf (CTRL+entrée) pour visualiser ce que fait mon animation par rapport au son.

  1. Je n'arrive pas à lire la piste, et les animations, en même temps sans simuler le .swf

Donc j'ai incorporer manuellement les frames… Ce qui est déjà bien chiant (j'aurais pu gérer de manière dynamique et coder, j'imagine, mais j'ai préféré faire à la main pour le moment).

Donc ennsimulant je vois à quel moment, au niveau des frames, et du son j'aimerais que l'action s'exécute. Mais plus on avance dans le temps, plus je dois me retaper touuuuut l'inlassable début déjà traité. J'me suis dit : Un petit bouton gotoAndPlay juste histoire d'accélérer l'aventure au moins qui pose problème.

  1. Un système de gotoAndPlay avance les images seulement, la piste sonore continu la ou elle en était.

Je suis donc très déstabilisé. J'aimerais au moins réussir à pointer vers un endroit sans me retaper toutes les premières minutes déjà synchronisé. Et pourquoi pas, apprendre à incorporer le nombre de frames dans un coin de l'écran en texte dynamique.

Si quelqu'un avait des réponses à ces problèmes ce serait très généreux !

Нова Проспект

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte