Problème de liaison via Nrf24l01

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour, il y a environ un ans j'ai acheter des arduino ainsi que des modules nrf24l01 pour un petit projet .

Mon soucis est que je n'ai jamais réussi a établir une liaison entre les 2 modules. J'utilise la librairie mirf, j'utilise un arduino uno et un mega

Pour les connectiques j'ai utilisé cela :

Image utilisateur.

Et pour les programmes ce sont ceux fournis en exemple avec mirf :

ping_server

ping_client

Voilà, et quand je regarde ce qui se passe sur le serial ça reste sur listening et begining, donc si quelqu'un a une idée de la source du problème qu'il n'hesite pas. Merci d'avance de vos réponses.

Édité par celiandu61

Je ne répond pas à la question, mais je te conseille de modifier ton titre car on ne sait pas exactement de quoi ça parle. Quelque chose comme Liaison entre Arduino et Module nrf24l01 serait selon moi plus adapté.

WinXaito

+0 -0

Salut,

Sur ton schéma tu ne montre que le branchement avec un arduino uno mais sur ce lien tu peux voir que le branchement sur une méga est différent du branchement sur une uno.

D'ailleurs le branchement représenté par ton schéma ne me semble pas correct il faut peut être revoir ça aussi.

Avec le lien que je t'ai mis plus haut j'ai réussi à faire communiqué deux arduino nano ensemble (bien que j'ai encore des dysfonctionnement)

+0 -0
Auteur du sujet

Ok, j'ai eu un peu de temps ce soir, j'ai regardé mais pour Mirf selon le tableau que l'on trouve à l'adresse que tu m'a envoyé c'est pareil sur tous les arduino.

Image utilisateur

Est-ce que j'ai juste mal compris ?

Édité par celiandu61

Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte