problème pour faire fonctiooner un moteur pas à pas (Easydriver-Arduino YUN)

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour, Je recherche de l' aide pour faire fonctionner un moteur pas à pas 'shinano EM463' avec une carte de controle EasyDriver et une carte ARDUINO YUN. Comme je suis un vieux débutant je me suis inspiré d'un exemple récupéré sur :'//www.norwegiancreations.com/2014/12/arduino-tutorial-stepper-motor-with-easydriver/' la seul différence c' est mon alimentation le m+ est connecté sur une alimentation de 6-8 vols externe. Rien ne ce passe? je vois bien défiler les commentaires sur le moniteur donc le prog. tourne bien. Le skelette:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
//int smDirectionPin = 2; //Direction pin
//int smStepPin = 3; //Stepper pin

int smDirectionPin = 2; //Direction pin
int smStepPin = 3; //Stepper pin

void setup(){
  /*Sets all pin to output; the microcontroller will send them(the pins) bits, it will not expect to receive any bits from thiese pins.*/
  pinMode(smDirectionPin, OUTPUT);
  pinMode(smStepPin, OUTPUT);

  Serial.begin(9600);
}

void loop(){
  digitalWrite(smDirectionPin, HIGH); //Writes the direction to the EasyDriver DIR pin. (HIGH is clockwise).
  /*Slowly turns the motor 1600 steps*/
  for (int i = 0; i < 1600; i++){
    digitalWrite(smStepPin, HIGH);
    delayMicroseconds(700);
    digitalWrite(smStepPin, LOW);
    delayMicroseconds(700);
  }

  delay(1000); //Pauses for a second (the motor does not need to pause between switching direction, so you can safely remove this)

 Serial.println("loop 1er for");

  digitalWrite(smDirectionPin, LOW); //Writes the direction to the EasyDriver DIR pin. (LOW is counter clockwise).
  /*Turns the motor fast 1600 steps*/
  for (int i = 0; i < 1600; i++){
    digitalWrite(smStepPin, HIGH);
    delayMicroseconds(70);
    digitalWrite(smStepPin, LOW);
    delayMicroseconds(70);

  }

  delay(1000);
  Serial.println("loop 2eme for");
}

Sur la carte EasyDriver je n' ai fais que les soudures pour les barrettes de connection. J' ai tester les bornes du moteur pour déterminer les connections. mais j' ai inversé ces connections voyant que ça ne marché pas. Je suis un vieux informaticien sans connaissance électronique. Voilà, si vous pouvez m'aider. Merci Guy

Edit de Thunderseb : mise en forme du code

Édité par Thunderseb

+0 -0

Salut,

Tu as posté ton message dans le mauvais forum. Tu aurais plutôt du poster dans le forum Sytèmes et Matériels. Je signale ton message à un staff, il pourra alors le déplacer dans le forum adéquat.

Aussi, quand tu insère un bout de code dans ton message, utilises les balises codes (<>), qui se trouvent dans ton éditeur. Ton code sera beaucoup plus lisible, tu recevras certainement des réponses plus rapidement. Si tu as des petits soucis avec le markdown utilisé, je te renvoie vers ce tutoriel.

Au passage, bienvenue à toi sur Zeste de Savoir ! :)

+0 -0
Auteur du sujet

Ok mais j' ai du faire une erreur car je pensais l' avoir mis dans systèmes et materiels. Tu penses que je dois reformuler mon message pour qu'il soit plus clair?

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte