Erreur dans la doc d'installation

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous,

Il me semble que la doc d'installation de Zds est erronée pour l'installation sous linux : http://zds-site.readthedocs.org/fr/latest/install/backend-linux-install.html . Dans le paragraphe sur les packets il est demandé d'installer libjpeg62-turbo, en revanche la commande en dessous pour Ubuntu reference toujours libjpeg8, la commande ne fonctionne donc pas (sous Debian). Il suffit de changer le nom du paquet pour que ca roule.

Anto59290

+0 -0
Staff

Salut !

Je suis justement en train de retaper la doc.

Dans le paragraphe sur les packets il est demandé d'installer libjpeg62-turbo, en revanche la commande en dessous pour Ubuntu reference toujours libjpeg8, la commande ne fonctionne donc pas (sous Debian).

Du coup tu utilises la doc pour ubuntu pour installer sous debian ou l'inverse ? Faut corriger quoi précisément ?

Je parle de JavaScript et d'autres trucs sur mon blog : https://draft.li/blog

+0 -0
Auteur du sujet

Salut Victor,

J'utilise la doc Ubuntu pour installer sur Debian. Dans laàdoc le texte est bon, mais la commande n'est pas bonne. Dans la commande retirer libjpeg8 et libjpeg8-dev, à remplacer par libjpeg62-turbo et libjpeg62-turbo-dev .

Autre chose qui me semble bizarre dans la doc il n'est indiqué de forquer le projet puis de cloner sur son disque (une ligne précise qu'il faut etre dans le repertoire du clone, sans detailler). Cela peut parraitre evident, mais cela ne l'est pas forcemment pour un débutant.

Anto59290

+0 -0
Auteur du sujet

Le npm install n'a pas foiré, j'ai essayé de supprimer le repertoire de module et de recommencer l'installation. Tout se passe bien a part quelques warnings sur des modules bientot obseletes.

npm install gulp se lance, charge, affiche des warnings de depreciations et se termine. Le build ne fontionne pas pour autant ensuite (meme erreur qu'auparavant).

+0 -0
Auteur du sujet

Problème résolu, mais je veut bien l'explication du comment. La méthode :

  • Mise a jour de npm avec npm install -g npm en su
  • npm install
  • Build avec npm run gulp build

Ma version de npm était bien supérieure aux requis de la doc, donc je comprend pas le pourquoi du comment. Mais ca marche. Merci à tous ;)

+0 -0
Staff

Ma version de npm était bien supérieure aux requis de la doc, donc je comprend pas le pourquoi du comment. Mais ca marche. Merci à tous ;)

La doc est vraiment datée. La version actuelle de npm c'est 3.8.5, et là tu utilisais 2.14. La version 3 de npm a changé énormément de choses, et y'a plus grand monde qui utilise la 2, même si elle est encore patchée.

Je parle de JavaScript et d'autres trucs sur mon blog : https://draft.li/blog

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte