Erreur de compilation de débutant

Oui je crois bien que c'est ça xD

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour, je susi en train de faire un dossier et j'ai beaucoup de problèmes de compilation. J'écrivais mon dossier sur un autre ordi et tout fonctionnait parfaitemenet et là sur les trucs basiques qui fonctionne farpaitement (qui trouver la référence ? :o) sur mon précédent ordi ne fonctionne plus ici et je trouve pas pourquoi. Voici le code qui pose problème et l'erreur à la suite.

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
\paragraph{}
Du text suivi de :

\begin{align}[rr]
y &= \sum_{i}^{n}w_i \times x_i$ \\
  &= X \times W \\
  &= XW
\end{align}

\end{document}

Et les erreurs de compilation de texstudio :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
Missing } inserted \end{align}
Missing { inserted \end{align}
Extra }, or forgotten $ \end{align}
Missing $ inserted \end{align}
Missing } inserted \end{align}
Missing } inserted \end{align}
Extra }, or forgotten $ \end{align}
Missing $ inserted \end{align}
Missing \endgroup inserted \end{align}
Missing } inserted \end{align}
Misplaced \omit \end{align}
Missing { inserted \end{align}

Toute les erreurs pointent sur la ligne suivant le \end{align}

Merci d'avance de votre aide !

+0 -0
Staff

Cette réponse a aidé l'auteur du sujet

C'est moi ou bien tu as un $ qui traine à la ligne 5 ? Si je l'enlève, tout fonctionne !

La coloration syntaxique de mon mode emacs a débusqué cette erreur tout seul. Par contre l'option rr n'a pas l'air de fonctionner…

+1 -0
Staff

Salut,

L'option [rr] est en effet non pris en compte, et c'est normal puisque cet environnement utilise seulement les & pour faire les alignements.

farpaitement (qui trouver la référence ? :o)

C'est ce bon vieux personnage un peu enveloppé. :p

I don't mind that you think slowly, but I do mind that you are publishing faster. – W. Pauli

+1 -0
Auteur du sujet

Oui le $ !

Copier coller a la noix x)

pour le [rr], c'est ce que j'avais vu dans un tuto et je l'ai utilisé (avec des c et des l) et ça marche très bien

Sinon question bonus : comment fait on les accents ? on est obligé de faire : 'e ?

+0 -0
Staff

pour le [rr], c'est ce que j'avais vu dans un tuto et je l'ai utilisé (avec des c et des l) et ça marche très bien

Tu es sûr que tu ne confonds pas avec array ?

Sinon question bonus : comment fait on les accents ? on est obligé de faire : 'e ?

Ricocotam

Utilise xelatex ou lualatex. L'UTF-8 est supporté et tu peux taper é directement.

I don't mind that you think slowly, but I do mind that you are publishing faster. – W. Pauli

+0 -0

Utilise xelatex ou lualatex. L'UTF-8 est supporté et tu peux taper é directement.

C'est mieux que \usepackage[T1]{fontenc} et \usepackage[utf8]{inputenc} ? Apparemment xelatex et lualatex sont conseillés pour gérer l'unicode (vu ici), mais par exemple ŵ ŷ ne donne rien avec, alors que ça fonctionne avec pdflatex.

+0 -0
Staff

Je ne sais pas comment tu t'y prends, mais ce code minimal donne bien le résultat escompté.

1
2
3
4
5
6
7
8
9
\documentclass{article}     
\usepackage{fontspec}
\usepackage{polyglossia}
\setdefaultlanguage{english}

\begin{document}

ŷŵéèòş
\end{document}

Après, pdflatex se fait vieux, xelatex et lualatex sont des projets qui ont été clairement mieux construits depuis le départ donc plus à même d'évoluer rapidement dans le futur proche.

I don't mind that you think slowly, but I do mind that you are publishing faster. – W. Pauli

+0 -0

Je prenais comme code le même qu'avec pdflatex, ce qui était sûrement n'importe quoi. Merci. Effectivement, ça fonctionne avec ce que tu donnes. Il faudra que je change un jour, alors.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte