Lancer le CD d'installation en mode UEFI

Pourquoi /sys/firmware/efi/efivars/ est-il vide ?

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Salut les agrumes,

Je m'amuse actuellement à essayer d'installer Archlinux dans une machine virtuelle VirtualBox (bien que j'ai une installation "physique" fonctionnelle), et j'ai un petit problème : comme l'indique le wiki, comme je souhaite l'installer en mode UEFI, j'ai bien coché la case EFI mode. Mais lorsque je regarde si le dossier /sys/firmware/efi/efivars/ contient des fichiers, il en résulte qu'il est vide.

Quelqu'un peut-il m'éclairer ?

EDIT : il m'installe sans problème le système sur un disque partitionné en gpt ; est-ce normal qu'il puisse le faire bien qu'il ne soit visiblement pas lancé en UEFI ?

Édité par mehdidou99

Plus on apprend, et, euh… Plus on apprend. | Coliru, parfait pour tester ses codes sources !

+0 -0

Le dossier que tu me présentes est censé être un système de fichier efivarfs. S'il n'y a rien, c'est que :

  1. soit l'EFI n'est pas détecté par le noyau
  2. soit le noyau n'a pas été compilé avec le support de efivarfs

Vérifie que le module noyau efivar est bien lancé (lsmod) ou essaie de lancer l'outil evivar -l (package efivar).

EDIT: je viens d'aller voir le paquet Linux d'Arch, normalement c'est compilé avec les bonnes options. Peut-être un bug côté VirtualBox ?

Édité par ntimeu

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte