Problème Gtk (début tuto GTK du site)

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour à tous,

J'ai voulu commencer le tuto sur Gtk du site pour enfin faire des interfaces propres à mes scripts Python cependant dès la verification de l'installation j'ai un soucis lorsque je tappe la commande :

1
from gi.repository import Gtk
1
__main__:1: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.

C'est la commande du tuto qui fonctionne moins bien sur Windows ou j'ai un soucis d'install ? (installé/désinstallé puis réinstallé en dernière version pour être sur)

Thanks :)

Édité par victor

+0 -0

Cette réponse a aidé l'auteur du sujet

Salut !

Est-ce que tu as essayé ce qu'il te propose de faire ? Rentre dans ton interpréteur :

1
gi.require_version('Gtk', '3.0')

Et ensuite fait

1
from gi.repository import Gtk

J'avoue que je n'avais jamais entendu parlé de ce problème :(

Mon projet : OpenPlane, un utilitaire en Java pour les pilotes, les vrais !

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte