Le symbole ℓ ne passe pas correctement en gras dans les tutoriels

L'auteur de ce sujet a trouvé une solution à son problème.
Staff
Auteur du sujet

Bonjour,

J'ai utilisé le symbole ℓ dans un tutoriel. En gras, comme ça : . Sauf que dans le tuto, il apparait comme ça : ℓ.

Là où c'est drôle, c'est que ça ne le fait que dans le tuto (pas dans les message du forum ni les MP), et que ça ne le fait pas avec les autres caractères peu usuels que j'utilise pour contourner le problème MathJax1, comme Δ, σ ou π.

Si vous avez un embryon d'idée, je suis preneur. Quoi qu'il en soit, je sais que le module Markdown est en réécriture, il faudra simplement vérifier que la nouvelle version n'a pas ce genre de problème (qui a ma connaissance n'arrive que dans mon tuto :ninja: ).

Merci.


  1. Et personne ne veut que je reparle de ça, j'imagine. Vous savez tous que à quel point je l'aime, lui et ses extraordinaires performances. 

Édité par Gabbro

Hier, dans le parc, j'ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+4 -0
Staff

Cette réponse a aidé l'auteur du sujet

Salut,

Je crois avoir trouvé d'où vient le problème.

Le font-style (gras, italique, etc.) est bien le même sur les tutoriels/articles et les forums, mais ce n'est la même police (font-family). En effet, sur les tutoriels et articles, on utilise une police serif, alors que sur les forums, on utilise une police sans serif. Apparemment, certaines polices n'auraient pas le caractère ℓ en gras.

Je n'ai pas réussi à trouver quelle police est incriminée exactement. Tout ce que je sais, c'est que sous mon Firefox (version récente sous Linux), quand j'enlève le style ZdS pour mettre le « style » par défaut de Firefox (qui utilise une police serif pourtant), j'ai le gras.

J'imagine qu'il n'y a malheureusement pas grand chose à faire pour régler ça…

+0 -0
Staff
Auteur du sujet

J'ai reproduit : j'utilise par défaut une police imposée (j'ai décoché « autoriser les sites à utiliser leur propre police »), et pourtant, en retirant les propriétés CSS liées aux polices avec l'outil « examiner l'élément », ça met bien le ℓ en gras.

Je suis assez étonné…

En tout cas, ce n'est effectivement pas lié au Markdown, que j'accuse donc un peu vite.

Édité par Gabbro

Hier, dans le parc, j'ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte