Problème sur module GSM SIM900

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour, Je viens de recevoir ce matin le module GSM SIM900 (celui-ci).

Et en voulant tester son bon fonctionnement, celui-ci m'affiche ca :

1
2
3
Debut du test du MODEM...ERREUR, pas de reponse du modem.
Verification du numero IMEI...Lecture IMEI du modem: 0
Reset du modem...Le Modem fonctionne correctement

avec le code suivant :

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
//**********************************************************
// test_modem
// tiptopboards.com - traduction FR 01 12 2014

// Created 12 Jun 2012  by David del Peral  modified 21 Nov 2012  by Tom Igoe
// http://arduino.cc/en/Tutorial/GSMToolsTestModem
//
// Cet exemple teste le bon fonctionnement du Modem du Shield GSM 
// Pas besoin de carte SIM pour cet exemple
// On affiche ensuite le n°IMEI de la puce
//************************************************************
// Important, déplacer les 2 jumpers du Shield  sur TX=2 Rx=3 
// ne pas les laisser sur 0 et 1 (positiion par défaut)
// Sinon ça interfère avec le serial port de l'Arduino

#include <GSM.h>  // librarie GSM
GSMModem modem;  // modem à verifier

// variable IMEI de la puce (chaque puce de shield à un n° différent)
String IMEI = "";

void setup()
{
  // initialise le  port serial de l'Arduino (Rx/Rx sur pins 0 1 )
  Serial.begin(9600);
   
  
  // Démarre le test du modem test (reset et vérifie la réponse)
  Serial.print("Debut du test du MODEM...");
  if(modem.begin()) 
    Serial.println("modem.begin() est OK");
  else
    Serial.println("ERREUR, pas de reponse du modem.");
}

void loop()
{
  // Lire le IMEI du modem 
  Serial.print("Verification du numero IMEI...");
  IMEI = modem.getIMEI();
  
  // Vérifier la réponse IMEI 
  if(IMEI != NULL)
  {
    // Afficher le n° IMEI de ce shield dans le serial monitor
    Serial.println("Lecture IMEI du modem: " + IMEI);
    // reset modem pourvérifierle booting:
    Serial.print("Reset du modem...");
    modem.begin();
    // Verifier une fois de plus  IMEI 
    if(modem.getIMEI() != NULL)
    {
      Serial.println("Le Modem fonctionne correctement");
    }
    else
    {
      Serial.println("Error: getIMEI() failed after modem.begin()");
    }
  }
  else
  {
    Serial.println("Error: ne peut pas lire IMEI");
  }
  // do nothing:
  while(true);
}

(étant une version Fr traduite du programme que l'on peut trouver dans /Examples/GSM/Tools/TestModem de l'IDE arduino )

Bien sûr, ce n'est pas vraiment le résultat dont je m’attendais. Sachant que j'ai testé le programme et la carte sur un Funduino UNO et un SainSmart MEGA 2560. Je l'ai aussi testé le programme "officiel" (version anglaise) et j'ai aussi testé le programme sur un arduino sans le module GSM. Et sur tous les testes que j'ai réalisé, j'ai toujours le même résultat.

Je ne comprend pas vraiment d'ou viens le problème, de moi, de la carte ou du programme …

(PS: J'ai aussi déplacé les 2 jumpers du module sur TX=2 Rx=3 et j'allumes le module en restant appuyé 2 sec sur "SIM900-POWER)

EDIT: la led "pwr" et rouge, la led "Status" est rouge et la led "NET" clignote en rouge. Je n'ai pas encore mis de carte SIM.

Édité par TheLumMys

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte