Problème d'installation d'ubuntu

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

Comme certain l'on peut-être vu sur mon précédent, je souhaitais mettre en Dual boot Windows et Ubuntu sur mon nouveau PC. Windows à été installé (Window 10 home).

Mais lorsque j'insère la clé avec Ubuntu 16.04 (Qui fonctionne correctement sur mon autre PC, j'ai deux options qui se présente):

  • Lancer en mode UEFI, qui m'affiche le menu "Try Ubuntu, Install Ubuntu, etc." et que je clique sur n'importe le quel des deux, l'écran devient noir et plus rien ne se passe.
  • Lancer directement, et la j'ai ce qui se produit sur la vidéo suivante:

Aller au alentour des 26s..

Je ne comprend pas cette erreur, est-ce que mon Processeur ou ma carte graphique ne sont pas supporté ?

  • Processeur: Intel core I7 6700K
  • Carte graphique: Gigabyte GTX 1080 Gaming G1
  • Carte mère: Asus H170 Pro Gaming

En vous remerciant !

Édité par WinXaito

+0 -0

je peux te conseiller une autre methode d'installation. je ne sais pas si ça sera une réelle . Juste pour essayer de t'aider. - Telecharge ce logiciel Unetbootin Ici

  • Tu l'ouvres normalement tu devrai comprendre à la vue
  • Selectionne ton ubuntu 16.04
  • Au démarrage comme tu le sais bien tu clique sur try ubuntu
  • A partir de l'interface graphique tu l'install , normalement il te montrera installer a coté de windows..

Venez :D Venez nombreux. L'Informatique comme Passion.

+0 -0

Moi, je dirais que vu que ça ne fonctionne pas, tu devrais m'envoyer tout ce joli matos ! :D

i915 c'est le nom du chipset vidéo Intel. Par contre, je sais pas pourquoi ça pose problème vu que tu utilises une cg à part et tu as déjà de l'affichage. C'est peut être un driver propriétaire qui n'est pas livré avec Ubuntu (j'ai déjà eu ce genre de problème, pas de driver wifi sur un chromebook alors que le PC n'a pas de port ethernet, c'était problématique).

Ici, ils disent qu'il faut toucher à un paramètre du BIOS, je te laisse tester et nous faire un retour.

It goes against the grain of modern education to teach children to program. What fun is there in making plans, acquiring discipline in organizing thoughts, devoting attention to detail and learning to be self-critical? – Perlis

+0 -0
Auteur du sujet

Je vais déjà tenter de mettre a jour le bios (de la ver. 0601 a la 1807). Car la dernière version date de novembre 2015. selon le lien donner par tleb.

Et comme j'ai pu le voir, tout ceux qui ont le problème est du au I7 6700K.

+0 -0
Staff

Aussi, ta carte graphique est beaucoup trop récente pour être supportée par les drivers propriétaires. Les drivers nVidia disponibles nativement dans Ubuntu 16.04 sont les 361.42 dont voici la liste des cartes compatibles : http://www.nvidia.com/download/driverResults.aspx/101423/en-us

Édité par SpaceFox

Auteur du sujet

Merci, donc la mise a jour du bios je change rien, je ne vois pas vraiment quelle option est a modifier dans le bios (comme j'ai pu lire une histoire de graphique avec le cpu).

Et spacefox, est il possible d'installer ces drivers sans l'os ? Et sachant que les drivers ont deja été installer sur Windows ne change rien ?

Edit: Selon ce lien http://www.starmate.fr/i915-component-master/ , il faut que je modifie l'option "Multi GPU dedicace monitor" à Enabled. Mais pour le moment je n'ai pas réussi à trouver cette option.

Édité par WinXaito

+0 -0

Et spacefox, est il possible d'installer ces drivers sans l'os ? Et sachant que les drivers ont deja été installer sur Windows ne change rien ?

WinXaito

Pour avoir des drivers au lancement, il faut que tu les ajoutes sur la clé que tu utilises pour l'installation. J'avais fais ça avec Fedora et des drivers WiFi mais je ne me souviens pas de comment j'avais procédé.

It goes against the grain of modern education to teach children to program. What fun is there in making plans, acquiring discipline in organizing thoughts, devoting attention to detail and learning to be self-critical? – Perlis

+0 -0

Spacefox, apparament c'est dans les drivers béta de Nvidia. Dans le changelog de la version 367.18 on peut voir "Added support for the following GPUs: GeForce GTX 1080".

À WinXaito, de trouver comment installer ceux-là. Quand tu arrive sur l'écran de login appuie sur les touches control et c successivement pour pouvoir commencer à te loguer.

1
2
3
4
5
sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt-get install nvidia-367 nvidia-settings

Source: http://sysads.co.uk/2016/05/nvidia-367-18-beta-linux-display-driver-released-how-to-install-on-ubuntu-16-04/

Édité par Hugo

Auteur du sujet

À WinXaito, de trouver comment installer ceux-là. Quand tu arrive sur l'écran de login appuie sur les touches control et c successivement pour pouvoir commencer à te loguer.

Hugo

Oui, mais quelle écran de login ? De 1, l'écran est noir après le bios, et deuxièmement, je n'ai pas de login Linux. :/

+0 -0
Staff

Cette réponse a aidé l'auteur du sujet

Le problème c'est que l'installation des drivers alternatifs dépend de la configuration exacte de la machine et de la (ou des) cartes graphiques.

Le Core i7-6700K contient un IGP (Intel HD Graphics 530, supporté par Ubuntu 16.04 mais pas avant) ; normalement l'installation et le système qui ne détectent pas la carte graphique principale basculent sur l'IGP, et si ça ne suffit pas utilisent les drivers VGA standard que toute carte est censée accepter.

Ça c'est la théorie. La pratique (en particulier dans la configuration IGP + carte dédiée), c'est qu'il arrive que le système se perde dans la configuration et n'arrive à démarrer sur aucun des deux GPU. Les actions sont :

  1. Dans l'EFI, changer la carte graphique déclarée comme principale.
  2. Déconnecter physiquement la carte dédiée, installer le système et remettre la carte ensuite.

J'ai dû activer l'étape 2 pour installer Ubuntu sur mon PC Dell du boulot, par exemple (mais même avec Windows y'avait des comportements louches).

Auteur du sujet

Je ne peux plus tester maintenant, mais actuellement cest en mode auto (Donc si il ne détecte pas la CG, il est sensé basculer). Je tenterai de forcer le "IGP").

Édit: Mais cest étrange, sans Windows j'arrivais accéder une fois sur 5 au menu "Essayer ou installer". Mais j'avais des bugs graphique ensuite.

Édité par WinXaito

+0 -0
Staff

Il faut savoir aussi que Windows ne libère pas forcément le matériel proprement au reboot soft (sans arrête de l'alimentation). Je n'ai pas l'explication, mais je suppose un problème le microgiciel. Par exemple :

  • Sur mon PC perso j'ai un dual-boot avec la partition NTFS dans le fstab. La procédure « d'arrêt » de Windows 8+ est en fait un reboot-hibernation (qui accélère fortement le boot suivant), la partition est marquée comme occupée au re-démarrage ce que Ubuntu déteste. Il faut que je reboot (ce qui arrête Windows sans hiberner).
  • Inversement sur le PC du boulot, Windows ne laisse pas la carte réseau dans un état normal, et je suis obligé d'arrêter le PC électriquement si je veux du réseau au démarrage d'Ubuntu.

Ce genre de connerie peut expliquer ce que tu as vu comme comportement.

Auteur du sujet

J'ai donc forcé l'utilisation du cpu pour le graphique et changer la prise d'endroit et cela fonctionne !

Je laisse pour le moment le sujet ouvert, car je sens qu'ubuntu risque de tout me casser ou ne pas s'installer au bon endroit. Et également pour les drivers nVidia.

+0 -0
Auteur du sujet

Bon… L'installation d'Ubuntu à réussi comme je le voulais. Mais hélas..

Je me rend compte que c'est Windows qui est installé à la mauvaise place. Ce malin a mis son secteur d'amorçage sur mon HDD au lieu du SSD (Bien que les données Windows soit sur le SSD). (Enfin je crois, selon la capture ci-dessous).

Liste des partitions

Ce qui me cause un problème, au démarrage, Windows ce lance directement. (Logique, car le HDD est lu avant le SSD, mais le SSD n'est pas dans la liste, donc je ne peux pas le mettre avant.. >_< )

Et si je boot sur le SSD (Manuellement depuis le sélecteur de boot) le GRUB apparaît bien. Mais il ne reconnaît que Ubuntu (Logique aussi je pense, puisque Windows n'est pas sur le même disque).

Donc comment puis-je faire, sans devoir passer par ce sélecteur de boot à chaque fois que je veux aller sur Ubuntu ?

Ps: Et j'ai aussi une petite question, pourquoi linux a-t-il créer deux partition ? (Une ce nommant linux et l'autre Mode échec ou quelque chose du genre je crois) (La partition de 15.90Go, qui est tout de même <Importante>)

Edit: Si j'avais su j'aurais déconnecter le HDD pour l'installe de Windows et Linux..

Édité par WinXaito

+1 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte