Smiley après une citation

L'auteur de ce sujet a trouvé une solution à son problème.

Pareil si on a une citation et qu’après la citation on insert un smiley il est inséré dans la citation.

Je suis une citation

)
1
2
3
>Je suis une citation

:)

Pourtant si je met un point devant

Je suis une citation

. :)

1
2
3
>Je suis une citation

. :)

Edit: Ce n’est pas vraiment le même bug, même si je pense que c’est lié. Mais ça m’est déjà arrivé quelques fois de vouloir ajouter un smiley après une citation, mais c’est impossible :p

Édité par WinXaito

+0 -0

En fait il suffit que le smiley ne commence pas par :

Exemple :

Citation

;)

Pour mettre quand même un smiley commençant par : on peut faire ça :

Citation

:)

1
2
3
4
> Citation
 :

:)

Autre bug ligne 2, je suis obligé de mettre une espace avant les : pour que ça s’affiche en code, mais il ne faut pas en mettre dans le message.

“I don’t love studying. I hate studying. I like learning. Learning is beautiful.” – Natalie Portman

+0 -0

Autre bug ligne 2, je suis obligé de mettre une espace avant les : pour que ça s’affiche en code, mais il ne faut pas en mettre dans le message.

En effet, tu as posté pendant que je jouais avec les bugs (citer mon message).

1
2
3
4
5
6
> sdg

> sdg
:Coucoubis

fin
Coucou

````

sdg

1
2
> dfgsdf
:

Étrange.

blabla

:)

Édité par blo yhg

+0 -0

Ha marrant je tombe sur ce sujet par hasard alors que j’ai implémenté ce bug dans le nouveau markdown il y a quelques jours !

Du coup je vais faire machine arrière et supprimer le raccourci pour la source des citations vu que ça semble pas souhaité.

Cest quoi les autres bugs que vous voyez ?

Le saviez-vous ? Chaque -1 que vous mettez vous fait gagner un point de QI.

+0 -0

¡Olà!

Je vais "profiter" du sujet, on parle de smileys qui commencent par des caractères qui servent à notre surcouche Markdown…

J’ai aussi eu droit à un souci quand j’ai fait des mises à jour sur le tutoriel WAMP. A un moment, on a l’IPv6 ::1 qui apparaît dans un pavé de code, dans les extraits du fichier hosts de Windows. Et ben le fait qu’il y ait un : en début de ligne fait finir le bloc de code, et du coup inverse ce qui devrait être du code et ce qui ne devrait pas. Pas totalement pratique, même si je reconnais que le cas que je signale est très particulier.  ^^

Evitez qu’on vous dise de les lire : FAQ PHP et SymfonyTutoriel WAMP • Cliquez 👍 pour dire merci • Marquez vos sujets résolus

+0 -0

Pouvez 1/ vérifier que c’est toujours présent sur le futur zmarkdown 2/ si c’est le cas vérifier que c’est vraiment un bug dans le moteur markdown et pas dans votre compréhension du markdown 3/ si vraiment, ouvrir un bug sur le repo zmarkdown.

Ce qui est certain c’est que rien ne sera corrigé dans le moteur actuel.

Édité par victor

Le saviez-vous ? Chaque -1 que vous mettez vous fait gagner un point de QI.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte