Erreur 404 sur l'envoi en validation d'un article

Pourtant l'article semble avoir bien été envoyé !

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

Je me suis dis en relisant la définition des tribunes que ma récente tribune serait aussi bien transformée en article. J’ai donc entrepris de la convertir (via exportation/importation en modifiant le manifest) et de la soumettre à validation. Et voici ce que j’ai eu quand j’ai lancé l’envoi en validation :

http://prntscr.com/g5bbqb

Il semblerait que l’article soit envoyé en validation d’aprés le bandeau vert, mais il y a quand même une erreur 404.

Si cela peut aider, je n’ai pas mis l’article en béta avant de l’envoyer à la validation et il a exactement le même nom que la tribune déjà publiée. Je n’ai à priori pas trouvé de bug similaire en cherchant sur le forum, d’où ce message. ;)

EDIT : il semblerait qu’il me soit également impossible d’accéder à l’article maintenant. Il apparait bien dans ma liste d’articles mais quand je clic dessus j’ai aussi une erreur 404. Dans ma liste d’articles il apparait bien avec la mention "en validation".

Édité par Demandred

"Toute extrapolation est valide dès lors que son résultat m’est sympathique." Loi de Lomborg

+0 -0
Auteur du sujet

Intéréssant. Pour que je sois sur, on parle bien de ta tribune sur R ? Et est ce que tu a "importé une nouvelle version" ou "importé un nouveau contenu" ?

pierre_24

Oui on parle bien de la tribune sur R (c’est ma seule tribune en même temps :p ).

J’ai fais importer un nouveau contenu a partir d’un nouvel article vierge, j’ai ajouté une vignette et j’en envoyé en validation et ça à produit le bug !

EDIT : il semblerait qu’il me soit également impossible d’accéder à l’article maintenant. Il apparait bien dans ma liste d’articles mais quand je clic dessus j’ai aussi une erreur 404. Dans ma liste d’articles il apparait bien avec la mention "en validation".

Édité par Demandred

"Toute extrapolation est valide dès lors que son résultat m’est sympathique." Loi de Lomborg

+0 -0

J’ai fais importer un nouveau contenu a partir d’un nouvel article vierge, j’ai ajouté une vignette et j’en envoyé en validation et ça à produit le bug !

Demandred

Ce serait pas dû au manifest.json de l’archive ? Je crois qu’il faut le modifier avant de l’importer, parce qu’il contient un paramètre "type": "OPINION" dans le cas d’une tribune, qui devrait être "type": "ARTICLE" dans ton cas.

"Les accidents dans un système doivent se produire, mais il n’est pas obligatoire qu’ils produisent pour vous et moi." Laurence Gonzales - Deep Survival

+0 -0
Auteur du sujet

Ce serait pas dû au manifest.json de l’archive ? Je crois qu’il faut le modifier avant de l’importer, parce qu’il contient un paramètre "type": "OPINION" dans le cas d’une tribune, qui devrait être "type": "ARTICLE" dans ton cas.

Non je ne pense pas, car j’ai bien modifié le manifest avant l’importation et mon article est importé en temps qu’article, l’importation fonctionne donc correctement.

D’ailleurs j’avais fais une faute de frappe lors d’une première tentative d’importation (j’avais mis le type à "ARITCLE" au lieu de "ARTICLE") et le contenu avait été importé en temps que… tutoriel !

Édité par Demandred

"Toute extrapolation est valide dès lors que son résultat m’est sympathique." Loi de Lomborg

+0 -0
Auteur du sujet

De plus en plus étrange. Et quel est le slug de cet article, du coup ?

pierre_24

Le slug est "manipuler-un-dataset-en-r-avec-le-package-dplyr". Il est probable qu’il s’agisse du même que celui de la tribune publiée.

"Toute extrapolation est valide dès lors que son résultat m’est sympathique." Loi de Lomborg

+0 -0

Il semblerait que l’article soit envoyé en validation d’aprés le bandeau vert, mais il y a quand même une erreur 404.

On n’a rien reçu : la liste à valider ne contient pas ton article.

Hier, dans le parc, j’ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0
Auteur du sujet

On n’a rien reçu : la liste à valider ne contient pas ton article.

C’est bizarre alors car dans ma liste d’articles il apparait bien, et il est affiché comme en validation. Si je filtre par "articles en validations" il apparait également.

"Toute extrapolation est valide dès lors que son résultat m’est sympathique." Loi de Lomborg

+0 -0
Auteur du sujet

Et tu vois mon article dans la bdd ou pas ? Car il apparait bien dans ma liste d’articles, mais impossible de cliquer dessus.

Édité par Demandred

"Toute extrapolation est valide dès lors que son résultat m’est sympathique." Loi de Lomborg

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte