démarrer une alim pc...grâce à une led-témoin !

a marqué ce sujet comme résolu.
Auteur du sujet

Bonsoir, Je cherche un moyen de démarrer une alim de PC (type ATX) à l’allumage d’un appareil quelconque, du moment que celui-ci à une led-témoin (les pin power-led d’une carte-mère de pc par exemple).

  • Coté alim ATX, il suffit de relier PS_ON à la masse pour que celle-ci démarre( suivant le modèle et l’âge de l’alim, il faudra peut-être également ajouter une résistance 10W entre le 12V et la masse).
  • Coté carte-mère, j’ai cru comprendre que la tension habituelle des led-témoin était le 5V, ?mA.

La question (ha, enfin ;) ) est donc :

Comment relier mes deux événements (led-témoin de la carte-mère qui s’allume = alim ATX qui démarre) ? Je ne trouve pas de relais qui collent à 5V et le -de mA possible, on m’a parler optocoupleur…bref, je suis u peu perdu

Merci à tous par avance pour vos réponses, et pardonnez-moi mon manque de précision(s), par pitié :D !

Édité par babas

Vous m’avez reproché de penser que j’avais toujours raison. Et je me suis rendu compte que vous aviez raison…. Mais allez savoir si j’ai raison !

+0 -0

Un relais classique ne semble pas convenir ici, si c’est une LED, on a entre 5 et 10mA, donc à la limite, peut-être qu’un relais reed ferait l’affaire, mais il faudrait être sûr que ton pin puisse donner 10mA (on en trouve sûrement avec des résistances de bobines plus fortes, j’avoue n’avoir pas beaucoup cherché).

L’optocoupleur est peut-être la solution qu’il te faut, mais il faut brocher le transistor de sortie :

Montage à optocoupleur
Montage à optocoupleur

Enfin, je peux te proposer le montage suivant, à base de transistors, probablement moins cher qu’un opto (encore que ce soit discutable), mais qui n’a pas d’isolation galvanique – c’est-à-dire qu’il faudra relier tes masses – entre l’alim et la carte mère :

Montage à transistors
Montage à transistors

NOTE : Stranger donne la solution du relais mécanique piloté par transistor, qui est en soi une bonne solution… à condition que tu ais accès au +5V de la carte (je pense que ce n’est pas le cas), et qu’elle puisse fournir un bon courant.

Voilà, plusieurs solutions comme souvent en électronique, si tu as besoin d’explications de fonctionnement, n’hésite pas à demander.

« La sottise, l’erreur, le péché, la lésine occupent nos esprits et travaillent nos corps » – Charles Baudelaire, Les Fleurs du Mal

+1 -0

Salut, l’optocoupleur est une bonne idée, ca protègera (un peu) l’appareil émetteur (pas de retour de courant possible), en fonction du type de relais et de la qualité du signal de l’appareil émetteur je rajouterais aussi un montage monostable ,pour éviter les déclenchement intenpestifs…

Pour le reste, comme la dis @Stranger, un transistor (type mosfet) qui actionne un relais mécanique (à préférer à un relai "électronique", en considérant que ton alim n’a pas besoin de s’allumer plusieurs fois par seconde ^^). Il te faudra donc une source de courant additionnel pour piloter tout ça par contre :)

EDIT : doublé par Talone , le monostable se mettrai juste apres l’opto pour moi

+1 -0

Yep, j’ai hésité sur le monostable, en fait tout dépends de l’entrée ; en général, je dirais que c’est une précaution un peu démesurée, et qu’un condensateur sur l’entrée et la sortie devraient faire l’affaire pour subvenir aux pics de courant et lisser les tensions d’E/S, les discontinuités sur une carte mère étant en réalité quasiment inexistantes.

Édité par TAlone

« La sottise, l’erreur, le péché, la lésine occupent nos esprits et travaillent nos corps » – Charles Baudelaire, Les Fleurs du Mal

+0 -0
Auteur du sujet

Houla, j’ai raté beaucoup de monde :D !

La solution de l’optocoupleur semble pour moi être la meilleur solution, j’ai accès à l’alimentation 5v de la carte-mère (pin power_led de la carte-mère), mais je préfère opter pour une isolation des deux systèmes (carte-mère et mon bricolage) par mesure de sécurité.

@Talone, aurais-tu l’amabilité de m’envoyer le schéma de l’option optocoupleur avec les deux condensateur dont tu parle ensuite, je suis totalement incapable de les ajouter moi-même, electroquiche que je suis :/ .

J’ai également trouvé l’info du 5Vsb alimenté en permanence sur les alim ATX, je pense d’ailleurs utiliser cette tension pour alimenter le circuit du relais.

Voici donc comment cela devrait fonctionner finalement :

  • circuit relais alimenté en permanence en 5V (via 5Vsb pin 9 violet) et relié à la carte-mère via optocoupleur
  • à l’allumage de la carte-mère, l’optocoupleur ferme le circuit en reliant les fils PS_ON et GND de l’alim ATX

Merci pour votre aide, je ne m’en sortirais pas sans vous ! PS : pouvez-vous me détailler un poil plus le schéma, R et Q étant de totales inconnus pour moi :D

@Eskimon, ça fait très longtemps en effet, sûrement des années…comment vas-tu ? (on passe en MP si tu veut :) )

Édité par babas

Vous m’avez reproché de penser que j’avais toujours raison. Et je me suis rendu compte que vous aviez raison…. Mais allez savoir si j’ai raison !

+0 -0

Je crois que tout n’est pas clair, laisse-moi donc reprendre : l’optocoupleur est une isolation suffisante en soi, ni les masses, ni les alimentations sont partagées des deux côtés du circuit. En pratique, c’est juste une LED d’un côté, et un interrupteur commandé en lumière de l’autre ; lors de l’allumage de la LED, l’interrupteur devient fermé, il fonctionne donc sensiblement de la même manière qu’un relais, avoir les deux est donc a priori inutile.

Je devais être fatigué hier, et j’ai donc mal lu ton besoin initial (j’ai fait passer PS_ON à 12V lors de l’allumage de la carte mère), le montage sera donc plus simple, le schéma final est le suivant :

Schéma final
Schéma final

Quelques notes :

  • j’avais fait une bourde hier, mon Vbe était appliqué en direct à la résistance, ce qui ne limitait pas du tout le courant, et pouvait aller jusqu’à casser le transistor ;
  • ajout d’un condensateur d’entrée (pas en sortie, finalement, car ça causerait plus de problèmes que ça n’en résoudrait) ;
  • résistance d’entrée pour la LED, à voir en fonction du circuit d’entrée, il faudrait la mettre en premier lieu, et l’enlever éventuellement si ça ne fonctionne pas ;
  • rail +12V transformé en rail +5V pour une utilisation avec le 5V toujours disponible.

Pour une petite explication du fonctionnement, lorsque l’entrée va passer à 5V, le condensateur va se charger, ce qui permet de continuer à alimenter l’optocoupleur si il y a des petites coupures de l’entrée, puis la LED de l’optocoupleur va s’allumer via la résistance R1, prévue pour donner environ 10mA (51.3330=0.0106A\frac{5 - 1.3}{330} = 0.0106 A). De l’autre côté, le transistor (« interrupteur ») contenu dans l’optocoupleur va faire passer un courant dans R2, ce qui va amener le potentiel PS_ON très proche de 0V.

Lorsque le 5V n’est pas disponible, la LED est éteinte, le transistor bloqué (pas de courant), et donc PS_ON est à environ 5V. Il faudra ajuster R2 en fonction de l’optocoupleur, et surtout de la charge de sortie (teste 10k, puis 1k, puis…).

« La sottise, l’erreur, le péché, la lésine occupent nos esprits et travaillent nos corps » – Charles Baudelaire, Les Fleurs du Mal

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte