Ignorer la modification d'un fichier setting avec git ?

Ne pas commit un changement

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

J’aimerais modifier mon fichier setting comme ceci : https://github.com/zestedesavoir/zds-site/issues/5287

Comment faire pour que le changement ne soit pris en compte lors d’un changement de branche ou si je fais : git commit -av ?

J’ai essayé des commandes par moi même, j’ai failli perdre mon travail lors du commit en voulant revenir en arrière. En faisant git rm --cached <file>, git considérait le fichier effacé alors qu’il ne l’était pas et voulait envoyer ce changement à l'origin. :lol:

Bon vol,

A

Édité par A-312

+0 -0

Euh … Ne pas utiliser '-a' ?!

Tu fais git status, tu regardes les fichiers qui t’intéressent puis tu fais git commit -p <FICHIERS>, et du sélectionne les modifications à commit.

ache.one                 🦹         👾                                🦊

+1 -0
Auteur du sujet

@A-312 tu développes directement sur une machine distante ?!

SpaceFox

Je code sur plusieurs PC (dont certains avec des perfs réduites et sous Windows), je ne voulais pas avoir 3 versions d’espaces de dev différents.

nb : Et je ne prévois pas toujours à l’avance sur lequel je serais, je voulais pouvoir faire 3 lignes de code n’importe où sans me soucier de quel ordinateur j’utilisais.


Donc je ne peux pas ignorer un changement ? à l’esprit de .gitignore mais sans impacter ma branche distante?

Édité par A-312

+0 -0

git commit ne s’utile pas forcément avec -a, c’est même une mauvaise pratique de faire git commit -a sans avoir vérifié les fichiers modifiés.

Donc, non il n’y a pas d’exceptions à l’option all permettant de filtrer les fichiers modifiés à commit ^^"

Tu peux si tu le veux avoir un .gitinignore local par-contre, si c’est ce que tu cherches.

Édité par ache

ache.one                 🦹         👾                                🦊

+0 -0
Auteur du sujet

Je vérifie mes changements via le fichier qui est affiché quand on fait git commit -am. Je ne me vois pas sélectionner minutieusement chaque url/fichier - c’est très long! - à cause d’une modification de la configuration de mon espace de dev…

Édité par A-312

+0 -0

git commit -am n’affiche pas de fichier.

Je te conseil de faire une branch locale et de cherry-pick ensuite les commits que tu souhaites faire. Ou alors d’avoir un gitignore local si ça t’arrive souvent de modifier ton environnement de dev.

ache.one                 🦹         👾                                🦊

+0 -0

Je crois qu’on ne se comprends pas. L’option 'm' permet de justement ne pas proposer de saisir le message de commit.

Du coup, je viens d’essayer j’ai :

[master sha12] qsd
3 files changed, 143 insertions(+), 64 deletions(-)

ache.one                 🦹         👾                                🦊

+0 -0

Donc je ne peux pas ignorer un changement ? à l’esprit de .gitignore mais sans impacter ma branche distante?

A-312

Pas sur un fichier suivi, non.

Mais pour les settings qui sont un cas un peu plus particulier tu pourrais avoir deux solutions :

  • Que le fichier de settings en inclut un autre s’il existe dans le répertoire (par exemple un fichier non suivi settings/local.py).
  • Que tu utilises de toi-même un autre fichier (non suivi) et lance tes commandes Django en précisant le fichier de settings à utiliser avec DJANGO_SETTINGS_MODULE.
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte