Wifi public - Ubuntu - Ne marche pas

a marqué ce sujet comme résolu.

Bonsoir à tous.

J’ai un problème SVP.

J’ai mon PC portable sous Linux (Kubuntu 20 LTS). Et là pour des raisons pro je suis dans un hotel pour quelques nuits. J’ai donc urgent besoin de leur Wifi. Mais je n’arrive pas à m’y connecter.

Avec mon smartphone ça a marché : je me suis connecté à leur wifi (sans mot de passe), j’ai du accepter des termes et conditions (c’est comme un popup qui s’est ouvert tout seul). Et ensuite le Wifi c’est mis à marcher.

Mais avec mon PC portable je n’ai pas eu le fameux popup pour que je puisse accepter les termes et conditions… Et donc la Wifi ne marche pas. Pourtant en bas à droite (dans la barre des taches) c’est bien écris que je suis connecté au réseau. Mais quand j’ouvre mon navigateur pour ouvrir une page web, ça ne marche pas.

Une idée SVP ?

Edit : je précise que c’est la première fois que j’essaie de me connecter à un Wifi public.

Merci d’avance.

Salut,

C’est un problème que je rencontre très souvent sur les wifi publics, sans que j’en connaisse vraiment la cause.
Ça m’étonne que tu le rapportes pour Ubuntu, étant pour ma part utilisateur d’Archlinux, j’ai un live USB Ubuntu qui me permet souvent mieux de me connecter à de tels réseaux.

Ce que je peux te conseiller, si tu as firefox, c’est de te rendre sur http://detectportal.firefox.com et voir si ça te donne quelque chose. Parfois ça marche.

Salut,

C’est un problème que je rencontre très souvent sur les wifi publics, sans que j’en connaisse vraiment la cause.
Ça m’étonne que tu le rapportes pour Ubuntu, étant pour ma part utilisateur d’Archlinux, j’ai un live USB Ubuntu qui me permet souvent mieux de me connecter à de tels réseaux.

Ce que je peux te conseiller, si tu as firefox, c’est de te rendre sur http://detectportal.firefox.com et voir si ça te donne quelque chose. Parfois ça marche.

entwanne

Salut, et merci pour ta réponse. J’ai essayé ce que tu ma dis avec Firefox, mais ça n’a pas marché. ça me met que ce réseau nécessite que vous vous connectez à un compte pour utiliser internet. Bref, comme si j’essayer d’aller sur une page web quand je suis connecté au Wifi de l’hotel…

Une autre solution qui fonctionne parfois rarement, c’est d’essayer d’aller taper directement sur l’IP du routeur voir si ça te redirige sur un bon portail de connexion.

Autre idée, avoir en mémoire / historique les URL de certains portails fictifs et les essayer dans l’espoir de tomber sur le bon.

Désolé pour ces solutions bancales mais je n’ai rien plus à apporter.

Avec mon smartphone ça a marché : je me suis connecté à leur wifi (sans mot de passe), j’ai du accepter des termes et conditions (c’est comme un popup qui s’est ouvert tout seul). Et ensuite le Wifi c’est mis à marcher.

Tu peux donc connaître l’URL du portail avec ton téléphone ? Essaie de saisir cette URL dans ton navigateur PC pour te connecter au réseau.

Sinon, tu peux éventuellement voir ça avec le personnel de l’hôtel : ils sont censés t’aider sur ce sujet, surtout si cela fait partie de la prestation que ta société paie.

+0 -0

Avec mon smartphone ça a marché : je me suis connecté à leur wifi (sans mot de passe), j’ai du accepter des termes et conditions (c’est comme un popup qui s’est ouvert tout seul). Et ensuite le Wifi c’est mis à marcher.

Tu peux donc connaître l’URL du portail avec ton téléphone ? Essaie de saisir cette URL dans ton navigateur PC pour te connecter au réseau.

Sinon, tu peux éventuellement voir ça avec le personnel de l’hôtel : ils sont censés t’aider sur ce sujet, surtout si cela fait partie de la prestation que ta société paie.

sgble

Merci mais avec mon smartphone je ne vois pas l’url dans l’historique…

Le personnel de l’hôtel, déjà fait. Ils disent que ça vient de mon PC.

Bon, c’est un problème courant qui prend du temps à traiter.

Reprenons désolé, je pars des bases, ne le prend pas mal, ce message s’adresse un peu à tous les niveaux. Tu te connectes au Wifi, ça a marché. Mais ensuite tu n’as plus rien ?

1) Tu as une ip ?

Si tu fais ip a dans ton terminal ?

$ ip a
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet 192.168.9.54/23 brd 192.168.9.255 scope global dynamic noprefixroute wlan0
       valid_lft 84896sec preferred_lft 74096sec

J’ai caché les informations “ privées ”. Mais en gros, tu devrais avoir une IP 192.168.9.54 et un masque.

Tu peux obtenir le serveur du routeur (son IP) :

$ ip r
default via 192.168.9.254 dev wlan0 proto dhcp src 192.168.9.54 metric 303 

192.168.9.254 “ chez moi ”.

Tu as testé de ping 1.1.1.1 (CloudFlare)ou 8.8.8.8 (Google)?

$ ping 1.1.1.1

Si ça passe, souvent, tu as internet. Tu peux tenter de pinger zestedesavoir.com.

Aussi, souvent le DNS est bloqué. Et normalement, il n’y a qu’un seul DNS autorisé, c’est celui retourné par le DHCP. Le problème c’est que je ne connais aucun client DHCP qui retourne les informations d’options. Normalement, dhcpclient écrit ça dans un lease mais c’est pas pratique et il faut utiliser dhcpclient. (c.f. stackExchange).

Souvent, le routeur fait également DNS ou c’est le serveur à coté. Par exemple ici, le DNS autorisé par le réseau est 192.168.9.254 les autres sont interdits (mais j’utilise DNS-over-https pour contourner ça).

Pour le vérifier :

$ dig +short @192.168.9.254  ache.one
145.239.86.0

Tu auras peut-être une réponse en premier temps mensongère, ça sera alors l’IP d’un portail.

Tu peux tenter de vérifier que le DNS n’est pas bloqué :

$ dig +short @1.0.0.1  ache.one
145.239.86.0

Un dernière tentative qui a toute les chances de marcher et de changer l’adresse mac de ta carte Wifi par celle du téléphone (si tu connais l’adresse mac de la carte Wifi du téléphone). Sous Linux c’est quelque chose de très simple à faire :

# ip link set ethi0 a 12:34:51:23:45:ff
+0 -0

Bonjour,

1er solution, désactivez le mode avion.

Ouvrir le menu système en haut a droite sur la top bar Puis choisir "Wired Connected" (dépend de la version FR ou EN) Sélectionner votre réseau de l’hôtel qui correspond a votre étage Puis entrer le user et password

Si la fenêtre popup ne s’affiche pas, assurez vous de ne pas avoir un plugin qui bloque les popup.

Essayez ceci via le terminal : sudo dhclient

Un message devrait vous dire Warning: /etc/resolv.conf is not a symbolic link to /run/resolvconf/resolv.conf

Dans le cas de ce probleme, il suffit de suivre les commandes suivantes via le terminal:

sudo rm /etc/resolv.conf

sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf

sudo resolvconf -u

+0 -0

Merci encore pour vos aides.

@ache voici mes résultats :

ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 98:af:65:8a:9c:01 brd ff:ff:ff:ff:ff:ff
    inet 10.90.8.56/22 brd 10.90.11.255 scope global dynamic noprefixroute wlo1
       valid_lft 14396sec preferred_lft 14396sec
    inet6 fe80::632a:6a6c:dc59:32eb/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

ip r

default via 10.90.8.1 dev wlo1 proto dhcp metric 600 
10.90.8.0/22 dev wlo1 proto kernel scope link src 10.90.8.56 metric 600 
169.254.0.0/16 dev wlo1 scope link metric 1000 

ping 1.1.1.1

PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
ping: sendmsg: Opération non permise
ping: sendmsg: Opération non permise
ping: sendmsg: Opération non permise
ping: sendmsg: Opération non permise
Connectez-vous pour pouvoir poster un message.
Connexion

Pas encore membre ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte