Copy/Paste système sur VIM/Ubuntu

+ problème d'autocomplete

L'auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Hello,

J'ai un problème tout bête sous Vim. Je cherche à faire un copier/coller depuis le clipboard du système. (sachant que le copier/coller en console est évidemment la source de problèmes liés à l'indentation)

J'ai bindé leader p pour coller de la sorte:

1
nmap <leader>p "+p<CR>

Ceci ne fonctionne pas, je ne sais pas pourquoi, sous Arch c'était parfait :( . Si vous avez des idées…

Accessoirement, j'ai un problème d'autocompletion dans la console:

1
2
➜  Nek  vim ~/.vimr
_arguments:450: _vim_files: function definition file not found

Vous savez comment régler ce problème également ?

Merci d'avance !

Édité par Coyote

+0 -0

Cette réponse a aidé l'auteur du sujet

Suivant comment sont configurés console, système, et vim, le registre à employer est * et non + ; :h registers § 7 => regarde si ton vim est bien compilé avec +xterm_clipboard (:version te le dira). Pour le copier-coller qui fasse attention à l'indentation, tu as l'option 'paste'.

Pour la complétion, tu la fait avec quoi ? A supposer que tu appuies sur µ, tapes: :verbose imap ^Vµ et vois quel plugin cela te signales si tu ne le sais pas déjà – il est difficile de deviner d'où vient un bug quand il est lié à un plugin dont on ne sait rien.

@Eskimon, l'OP utilise vim et non un éditeur qui utilise des raccourcis clavier à la Dos/Windows.

PS: utilises le tag #vim pour les questions liées à vim STP PPS: ça serait bien de pouvoir corriger les tags mis par les OP

Édité par lmghs

+0 -0
Auteur du sujet

Merci lmghs :) . Effectivement, l'option xterm_clipboard n'était pas activée !

Du coup je suis tombé sur ça en cherchant, et dans l'issue ils parlent d'installer vim-gnome, ce qui règle le problème.

Pour l'autocompletion je parlais du terminal par contre…

Édité par Nek

+0 -0

@Eskimon, l'OP utilise vim et non un éditeur qui utilise des raccourcis clavier à la Dos/Windows.

Et alors ? Tu te mets en insertion et tu peux faire ton coller comme dans un terminal classique non ? (en tout cas je viens de tester a l'instant et ca marche chez moi…)

ZdS, le best du Zeste ! Tuto Arduino, blog, etc

+0 -0

Et cela ne marche pas chez moi, que ce soit avec gvim ou avec vim dans guake (sur une ubuntu accédée au travers d'un client NX (mais cela peut venir du client NX qui tend à saboter pas mal de choses)). La conf du terminal est propre à chacun. Et le clic milieu a limite plus de chances de marcher.

+0 -0
Auteur du sujet

@Eskimon Oui tu peux, mais le problème c'est que c'est interprété par des entrées clavier. Si tu as l'indentation intelligente activée, ton indentation finale est pétée car le "entrée" est interprété comme une entrée clavier, et du coup l'indentation automatique se met en marche, sauf que tu as aussi de l'indentation dans ton C/C…

+0 -0
Auteur du sujet

xterm_clipboard n'est accessible que dans un serveur X, aussi ? Quid des gens en ligne de commande ?

Richou D. Degenne

Ah parce que tu peux faire un copier-coller hors de serveur X ? :)

Sinon en interne dans Vim tu peux faire des copiers/coller sans problème avec y et p

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte