Erreur 500

L'auteur de ce sujet a trouvé une solution à son problème.

Ok, c'est encore un bug qui a généré des notifs multiples. Il devrait être réglé avec la v21 (lorsque cette PR sera migrée https://github.com/zestedesavoir/zds-site/pull/3954)

En attendant, il faudrait que tu ping vhf pour qu'on voit comment retirer une des deux notifs.

En tout cas peux-tu me préciser si :

  • tu es un follower d'un des auteurs du tuto?
  • tu as cliqué combien de fois sur "suivre le tuto"? Si la réponse est "aucune", es-tu le premier à avoir posté?
  • Combien y avait-il de message quand tu as posté un message si tu en as posté un?

@vhf, pourras-tu nous dire à quelles souscriptions sont liées ces notifs stp?

Édité par artragis

+0 -0

J'ai le même souci, je vais essayer de les retirer à tout le monde comme je l'ai fait la semaine dernière. Je vous tient au courant ici même.

EDIT : Trop casse gueule de faire ça en production vu le nombre de notifications concernées.

Édité par gustavi

"I think that it’s extraordinarily important that we in computer science keep fun in computing." – Alan J. Perlis

+0 -0
Auteur du sujet

Ok, merci pour ces infos !

Pour tes questions artragis, je suis un des auteurs du tuto, donc je pense que ça vient de là vu le bug reporté par Bullesdair ; dans mon cas je ne follow aucun des auteurs du tutoriel, logiquement je suis le tutoriel par défaut vu que je suis auteur, et je n'ai posté aucun commentaire.

Perso, j'ai aussi eu des notifications multiples (j'ai été auteur, mais ne l'étais plus lors de sa publication), mais j'ai cliqué sur toutes les notifications dans l'ordre, et elles sont toutes parties.

J'ai cessé de suivre pour éviter les ennuis.

Note : je crois bien que j'ai eu une première notification me disant qu'il y avait un message alors que je ne suivais pas le contenu.

Édité par Gabbro

Hier, dans le parc, j’ai vu une petite vieille entourée de dinosaures aviens. Je donne pas cher de sa peau.

+0 -0

En ce qui me concerne, je ne suis pas auteur du tutoriel, mais j'ai pourtant une erreur 500 quand je vais dessus (mais pas quand je suis déconnecté) et également quand je consulte le sujet lié à sa bêta (j'ai d'ailleurs reçu deux notifications permanentes aujourd'hui pour ce sujet).

Rectification : en fait, les notifications étaient pour le tutoriel et le sujet s'affiche correctement, mea culpa. Par contre, j'ai reçu deux notifications pour la publication du contenu.

Édité par gcodeur

Problème identique chez moi, co-rédacteur. Pour répondre aux questions d'artragis :

  • Je ne suis abonné à aucun des auteurs ;
  • Je n'ai jamais cliqué sur « suivre ce contenu », je ne peux pas l'ouvrir ;
  • Je n'ai posté aucun message.

Par contre j'ai trois notifications non lues (qui mènent toutes au tutoriel et donc à une erreur 500), avec de la plus ancienne à la plus récente : une de moi, une de SpaceFox, et une autre de moi (la notification issue de SpaceFox étant un lien vers son commentaire sur le tuto).

Édité par entwanne

Je pense avoir isolé le bug.

Tel que c'est parti, dès qu'Andr0 aura le temps de me répondre, on aura un fix qui fera le travail de cette manière :

  • il saura trier entre les notifications en double
  • il ne créera pas de nouvelles notifications doubles
  • et s'il venait à en faire, il nous préviendrait sur le sentry avec un peu plus d'info que ce qu'on a jusqu'à présent.

C'est donc en bonne voie de résolution.

+3 -0

Salut !

Les gens qui ont des notifications problématiques, pouvez-vous svp vous connecter sur https://beta.zestedesavoir.com et me dire si elles y sont également présentes ?

Explication : beta.zestedesavoir est notre serveur de beta, sur lequel est déployé la prochaine version du site. La base de donnée vient d'être copiée de la prod vers la beta. La prochaine version du site devrait être déployée mercredi au plus tard si tout se passe comme prévu.

Vos retours à ce sujet sont importants, cette nouvelle version étant censée résoudre notamment ces problèmes de notifications.

Le saviez-vous ? Chaque -1 que vous mettez vous fait gagner un point de QI.

+0 -0
Auteur du sujet

Salut !

Les gens qui ont des notifications problématiques, pouvez-vous svp vous connecter sur https://beta.zestedesavoir.com et me dire si elles y sont également présentes ?

Explication : beta.zestedesavoir est notre serveur de beta, sur lequel est déployé la prochaine version du site. La base de donnée vient d'être copiée de la prod vers la beta. La prochaine version du site devrait être déployée mercredi au plus tard si tout se passe comme prévu.

Vos retours à ce sujet sont importants, cette nouvelle version étant censée résoudre notamment ces problèmes de notifications.

victor

EDIT : j'ai dû me fourvoyer entre mes onglets. :-° Tout est niquel sur la bêta.

Édité par Smokiev

J'avais déjà testé sur la beta l'autre jour, je viens de le refaire est le constat est similaire : les notifications intempestives sont toujours là, quand je clique sur l'une d'elles j'atterris sur une page en erreur 500, mais l'ensemble de ces notifications disparaît bien ensuite.

Donc je ne sais pas si cette 500 est volontaire, mais ça règle bien le problème.

Super, merci beaucoup. Le fait qu'elles disparaissent est bon. L'erreur 500 j'ai fait une PR y'a quelques heures à ce sujet, je pense que c'est super facile à éviter.

Le saviez-vous ? Chaque -1 que vous mettez vous fait gagner un point de QI.

+0 -0
Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte