Enregistrement de mon écran donne un rendu noir

L’auteur de ce sujet a trouvé une solution à son problème.
Auteur du sujet

Bonjour,

Pour mon projet, j’aimerais faire des vidéos, mais j’ai un problème: quoi que je fasse, mon écran n’est pas filmé et dans le fichier de sortie, j’ai juste un écran noir.

Je suis sur Linux et j’ai testé avec du plus basique logiciel de record avec aucunes options, jusqu’à un peu plus évolué comme OBS Studio, mais rien dans tous les cas. Même le retour vidéo d’OBS donne un écran noir, on peut voir seulement la souris.

retour vidéo
vidéo

J’ai soupçonné les drivers de ma cg, mais elle est un peu vieille (Radeon HD 6850) et je n’arrive plus à en trouver pour elle pour les mettres à jour (ou je cherche mal sinon :D )
La capture de la webcam fonctionne correctement, ainsi que toutes les autres sources différentes de l’écran en lui même proposés par OBS.

Merci d’avance,
Ardakaniz

Édité par Δrdakaniz

Salut,

As-tu essayé d’utiliser la commande ffmpeg (edit : histoire d’avoir éventuellement plus d’infos), par exemple comme ci-dessous ?

1
$ ffmpeg -f x11grab -i :0.0+0,0 -framerate 25 -video_size 1024x768 test.mp4

Tu peux bien entendu remplacer la taille précisée par celle de ton écran.

Édité par Taurre

+0 -0
Auteur du sujet

Même résultat : écran noir. (La sortie de ffmpeg si ça peut être utile: https://pastebin.com/vHY8vgKQ)

Mais en lançant VLC depuis mon terminal, j’ai vu qu’il affichait une erreur au lancement de la vidéo: vdpau_avcodec generic error: unsupported codec 28 or profile 244. J’obtiens cette erreur seulement avec la sortie de ffmpeg (qui est au format mp4) mais pas avec celle d’OBS (format flv)

Édité par Δrdakaniz

Mmm… Cela va faire pas mal de choses à récupérer, mais :

  • Que te retourne la commande xrandr ?
  • Utilises-tu plusieurs écrans ?
  • Que contient le fichier /var/log/Xorg.0.log ?
  • Que te retourne la commande lspci | grep VGA ?

Édit :

Mais en lançant VLC depuis mon terminal, j’ai vu qu’il affichait une erreur au lancement de la vidéo: vdpau_avcodec generic error: unsupported codec 28 or profile 244. J’obtiens cette erreur seulement avec la sortie de ffmpeg (qui est au format mp4) mais pas avec celle d’OBS (format flv)

Ardakaniz

Du côté de ffmpeg, tout semble normal, c’est peut-être juste VLC qui ne supporte pas le codec H264. Logiquement, tu devrais pouvoir lire la vidéo avec ffplay.

Édité par Taurre

+0 -0

Cette réponse a aidé l’auteur du sujet

Mmm… Je vois que tu utilises donc Wayland et non X11. Vu que tu utilises Gnome, j’en déduis que lorsque tu ouvres ta session via gdm tu as expressément choisit « Gnome avec Wayland ». Est-ce que tu rencontres le même problème en recourant au bon vieux serveur X11 ?

+2 -0

Bof, ce n’est pas vraiment une solution à long terme de continuer d’utiliser X11. Certes il fonctionne encore très bien et est encore très utilisé mais Wayland est le futur.

tleb

Wayland est encore expérimental tant que maintenant, non ? Je veux dire, les bibliothèques graphiques comme GTK+ ont introduit son support, mais ce n’est pas encore une solution « stable », je me trompe ?

Sinon, je plussoie la suggestion de tleb : n’hésite pas à faire remonter ton bug auprès des développeurs de Wayland (à voir d’ailleurs si tu n’es pas le seul à le rencontrer), cela les intéressera sûrement. :)

Édité par Taurre

+0 -0
Auteur du sujet

Ben, tiens, ce que je viens de trouver sur le lien de tleb:

One of the features of Wayland is its security design, which helps to guard the user against malicious apps. Apps can no longer see everything on the screen and spy on you. But that also means you cannot run a common application and use it to make a screenshot or a screencast of your desktop

EDIT: et il ne semble pas pouvoir l’autoriser pour l’instant:

The only workaround at this point is to switch back to Xorg instead of Wayland.

http://support.hubstaff.com/screenshot-capture-support-wayland-linux/

Édité par Δrdakaniz

Wayland est encore expérimental tant que maintenant, non ? Je veux dire, les bibliothèques graphiques comme GTK+ ont introduit son support, mais ce n’est pas encore une solution « stable », je me trompe ?

Taurre

Fedora 25 est livré par défaut avec donc je pense qu’on peut désormais considérer le projet comme stable.

C’est quand même assez triste d’empêcher ça, ça aurait été pratique que ça puisse fonctionner avec les permissions qui vont bien (qu’on n’attribue pas à l’utilisateur lambda).

Vous devez être connecté pour pouvoir poster un message.
Connexion

Pas encore inscrit ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte