État de la béta

Les mises à jour

a marqué ce sujet comme résolu.

Bonjour,

Petit message pour vous annoncer que la v30 est en bêta ! :pirate:

Les changements visibles principaux sont :

  1. l’amélioration de l’accessibilité visuelle du site web
  2. la refonte de l’affichage des messages
  3. l’amélioration de l’accessibilité du thème de coloration syntaxique
  4. l’anéantissement (on espère) des bugs liés aux slugs dans les contenus

Il y a bien entendu des changements invisibles mais nécessaires :

  • l’amélioration du code qui gère les notifications (ce qui devrait réduire le nombre de bugs liés aux notifications ou permettre plus facilement leur correction) ;
  • le début du long travail pour ne plus utiliser de jQuery ;
  • la préparation du passage à Django 3.2 LTS ;
  • plein d’autres petits détails.

Merci d’aller jouer un peu sur le serveur de bêta et nous dire ce que vous en pensez !

+11 -0

Hey ! J’aime beaucoup les changements de contraste, c’est top niveau lisibilité.

Le travail accompli sur les actions réalisables dans les forums me paraît bien aussi. Deux réserves à ce sujet toutefois :

  1. au survol sur les trois points, les actions possibles (« Citer », « Signaler », « Marquer comme non-lu ») apparaissent instantanément. Est-il envisageable d’afficher ces actions au clic plutôt qu’au survol ? En fait, la fonction existe déjà dans les paramètres : « Dérouler les menus au survol » peut être coché ou décoché, mais n’agit à cet endroit.
  2. Dans le même genre, et c’est en fait lié, ça me perturbe que le bouton « Citer » soit déplacé vers la gauche en allant sur les trois points. Ça donne l’impression qu’il faut à nouveau bouger la souris pour citer.

Pour le reste, j’aime beaucoup. :)

Merci pour tes retours !

au survol sur les trois points, les actions possibles (« Citer », « Signaler », « Marquer comme non-lu » apparaissent instantanément. Est-il envisageable d’afficher ces actions au clic plutôt qu’au survol ? En fait, la fonction existe déjà dans les paramètres : « Dérouler les menus au survol » peut être coché ou décoché, mais n’agit à cet endroit.

C’est effectivement un retour qu’on a eu plusieurs fois, et une PR en ce sens est en cours. Ce ne serait pas non plus lié à cette option (qui ne concerne que les menus de l’entête du site) mais toujours au clic, cependant.

Peut-être faudrait-il la clarifier, en attendant je ne pense pas que ce soit pertinent de permettre le changement ici, surtout que ça rend le code bien plus complexe alors qu’actuellement, on s’en sort sans la moindre ligne de JavaScript. Cela dit, si la demande est réelle, ça s’envisage.

Dans le même genre, et c’est en fait lié, ça me perturbe que le bouton « Citer » soit déplacé vers la gauche en allant sur les trois points. Ça donne l’impression qu’il faut à nouveau bouger la souris pour citer.

La PR précédente adresse également ce point. :) Au vu du fond bleu indiquant que toute la largeur est cliquable, je ne pensais pas que ça perturberai, mais il semblerait que si, donc adaptation il y aura.

+1 -0

Salut,

Cette nouvelle version est vraiment très agréable, propre et claire !

Une petite réserve seulement, les images des tutos en une sont souvent pixelisés, car trop petits à la mise en ligne, certainement. Il faudrait peut-être faire une précision dans la partie des tutos demandant un logo d’assez grande taille et de bonne qualité. Cela ferait peut-être un peu plus propre.
J’ai pas encore fait le tour de la bêta, mais je reviens ici si j’ai d’autres choses à redire…

En tout cas, bravo ! ;)

+2 -0

J’aime beaucoup.

Juste un détail qui me chagrine, le positionnement de la date des posts. Ne serait-ce pas préférable de l’indiquer dans la partie supérieure ? Dans l’espace à côté du pseudo ? (Version mobile)

+1 -0

Hello

J’aime bien aussi, l’accent apporté sur la lisibilité est vraiment un bon point à mon avis !

Petit détail : apparemment, les blocs secret sont (parfois ?) totalement masqués aux anonymes dans les sujets. Par exemple ici sur la version 29.3b et ici sur la version 30, la table de vérité n’apparaît pas sans être connecté sur la beta, alors qu’elle est dans le DOM. Es-ce qu’il s’agit d’un comportement voulu ? Histoire que je sache qu’il me faut revoir mes messages et tutoriels  :)

+1 -0

Bonjour,

Pour info, j’utilise une police perso (OpenDyslexic), avec une taille minimum, et je zoom. Ça a tendance à casser certains sites. Jusqu’ici, pas ZdS. Sur la béta, si. Faudra surement que je vous fasse un retour détailler (pas le temps ce soir), mais la page d’accueil est un peu cassée, et le forum est compressé par rapport à aujourd’hui (plus de message affichés plus petit — je ne compte pas la diminution des info annexes, comme les casquettes ou l’édition de message). Images :

Accueil aujourd'hui
Accueil aujourd'hui
Accueil béta
Accueil béta
Forum aujourd'hui
Forum aujourd'hui
Forum béta
Forum béta

À vue de nez, c’est écris plus petit, certains interlignes ont été diminués (entre le titre et les sous tire sur l’accueil), et la mise en page semble cassé un peu partout sur l’accueil.

Dans les forums, je sens que le but est se concentrer sur le message et d’augmenter la lisibilité, mais il y a un truc qui cloche. J’ai mis un moment à mettre le doigt dessus (même taille, c’est plus noir, mais ça ne devrait pas poser de problème, même interligne…), mais je pense que c’est la distance à gauche entre le bloc de texte et la boite du message. Ça va peut-être vous paraître complètement stupide, mais ça n’a rien à voir à mes yeux (pourris, je le concède volontiers), entre ces deux situations :

Béta normale
Béta normale
Béta avec un padding de 8px
Béta avec un padding de 8px

Après, c’est peut-être moi seulement, ou ma config qui est foireuse. Je voulais juste comprendre ce qui me gênait tant que ça dans les messages du forums…

+1 -0

Salut, merci pour tes retours !

et la mise en page semble cassé un peu partout sur l’accueil

Ce soucis (notamment les dates des contenus qui débordent sur leurs images) semble est le même que celui énoncé plus haut par pierre-24 ainsi que par d’autres personnes sur Discord, c’est-à-dire un soucis de cache qui n’est pas à jour. On ne sait toujours pas pourquoi et c’est assez difficile d’investiguer malheureusement.

Dans les forums, je sens que le but est se concentrer sur le message et d’augmenter la lisibilité, mais il y a un truc qui cloche. J’ai mis un moment à mettre le doigt dessus (même taille, c’est plus noir, mais ça ne devrait pas poser de problème, même interligne…), mais je pense que c’est la distance à gauche entre le bloc de texte et la boite du message. Ça va peut-être vous paraître complètement stupide, mais ça n’a rien à voir à mes yeux (pourris, je le concède volontiers), entre ces deux situations

Après, c’est peut-être moi seulement, ou ma config qui est foireuse. Je voulais juste comprendre ce qui me gênait tant que ça dans les messages du forums…

Sur la production la marge à gauche des messages est de 10px et sur la bêta elle est de 1 rem mais, en tous cas sur mon navigateur, il n’y a aucune différences car 10 px est égal à 1 rem. Soit c’est lié au même soucis que plus haut (un soucis de cache), soit c’est lié à ta config (qui ferait que 10 px n’est pas égal à 1 rem ?), soit il y a un beau bug fourbe quelque-part.

j’utilise une police perso (OpenDyslexic), avec une taille minimum, et je zoom

Est-ce que tu peux me donner la taille de la police et le niveau de zoom utilisés pour que je puisse essayer de reproduire ta config chez moi ?

+0 -0

Ce soucis (notamment les dates des contenus qui débordent sur leurs images) semble est le même que celui énoncé plus haut par pierre-24 ainsi que par d’autres personnes sur Discord, c’est-à-dire un soucis de cache qui n’est pas à jour. On ne sait toujours pas pourquoi et c’est assez difficile d’investiguer malheureusement.

J’ai vidé le cache avant mon message. De plus, dans certains cas (Explorons Wikidata), ça remonte partiellement dedans seulement, ça peut être autre chose que le cache.

Sur la production la marge à gauche des messages est de 10px et sur la bêta elle est de 1 rem mais, en tous cas sur mon navigateur, il n’y a aucune différences car 10 px est égal à 1 rem. Soit c’est lié au même soucis que plus haut (un soucis de cache), soit c’est lié à ta config (qui ferait que 10 px n’est pas égal à 1 rem ?), soit il y a un beau bug fourbe quelque-part.

Si je peux tester quelque chose, pas de problème. Mais j’ai vidé le cache de toutes les manières possibles, et ça reste.

Est-ce que tu peux me donner la taille de la police et le niveau de zoom utilisés pour que je puisse essayer de reproduire ta config chez moi ?

Avec Firefox 78.7.0esr, OpenDyslexic3, taille 13, taille minimal 12, zoom 110 %. Les pages web ne sont PAS autorisées à utiliser d’autres polices.

+4 -0

Est-ce que tu peux me donner la taille de la police et le niveau de zoom utilisés pour que je puisse essayer de reproduire ta config chez moi ?

Avec Firefox 78.7.0esr, OpenDyslexic3, taille 13, taille minimal 12, zoom 110 %. Les pages web ne sont PAS autorisées à utiliser d’autres polices.

J’ai pu reproduire le soucis. Sur la production les marges sont en px donc elles ne dépendent pas de la taille de la police mais sur la bêta elles sont en rem donc elles dépendent de la police, donc étant donné que tu as baissé la taille de la police sur ton navigateur de 16px à 13px la marge de de 1rem est est passée de 10px à 8,125px. J’ai vu avec @Amaury et on va repasser les marges en px ça résoudra ce soucis.

+2 -0

J’ai pu reproduire le soucis. Sur la production les marges sont en px donc elles ne dépendent pas de la taille de la police mais sur la bêta elles sont en rem donc elles dépendent de la police, donc étant donné que tu as baissé la taille de la police sur ton navigateur de 16px à 13px la marge de de 1rem est est passée de 10px à 8,125px. J’ai vu avec @Amaury et on va repasser les marges en px ça résoudra ce soucis.

Merci beaucoup. :)

J’ai vérifié par curiosité à l’aide d’un profil vierge, et une ligne en OpenDyslexic taille 13 est plus longue que la même en Roboco (police par défaut) taille 16. Donc les caractères doivent être nettement plus gros. Ça veut aussi dire que se baser sur la hauteur des lettres avec rem peut être trompeur, puisque leur largueur dépend fortement de la police.

Et ça explique aussi pourquoi certains sites sont cassés avec OpenDyslexic, la police est trop large. Mais ça doit fortement participer à la rendre plus lisible. ^^

+1 -0

J’aime beaucoup.

Juste un détail qui me chagrine, le positionnement de la date des posts. Ne serait-ce pas préférable de l’indiquer dans la partie supérieure ? Dans l’espace à côté du pseudo ? (Version mobile)

Arius

Je n’ai rien contre sur le principe, mais comment fais-tu dans des cas comme ça ?

Un message avec une grosse casquette, vue sur mobile. Le pseudo et la casquette prennent quasiment tout l'espace disponible.
Un message avec une grosse casquette, vue sur mobile. Le pseudo et la casquette prennent quasiment tout l'espace disponible.

C’est pour des cas comme ça que la date a été déplacé dessous.

Connectez-vous pour pouvoir poster un message.
Connexion

Pas encore membre ?

Créez un compte en une minute pour profiter pleinement de toutes les fonctionnalités de Zeste de Savoir. Ici, tout est gratuit et sans publicité.
Créer un compte